Maslow Home Maslow Community Garden

Im not able to calibrate chain lenght


#1

Hi all.

So i finally got my maslow kit. I was able to print the frame with my temporary setup.

I took the tempotaty setup apart and put it back together with the printed parts. During this process I have also upgraded to CG/firmware to 0.98 and the triangulation linkage kit

So, going through the calibration again, i was able to get to the very last step where it does two small cuts and measure the distance. However, right after it complete cutting, it gave me this error message “unable to find valid machine position for china lenght 1648.98 1649.99. Please calibrate chain lenght”

I went ahead and jump to the “calibrate chain lenght -automatic” follow the procedure. It gave me the same error after im done.

I have also try to restart GC, download fresh GC, reflash firmware, power cycle the control board. The error wont go away.

Someone please let me know what im doing wrong :frowning:

Thanks in advance!


#2

Do you recall what the approximate values were that you entered in for the calibration step?


#3

Distance between motor : 2858.61
Work area width: 2438.4
Work area height : 1219.2
Motor offset hight: 393.7 ( i think i did modified this value manually)
Distance berween sled mounting point: 304.165


#4

Sorry, I meant what your measurements was when doing the calibration.

No worries though.

There might some issue with auto calibration and the triangular kinematics. You should be able to measure the necessary bits manually and get going. I think only the rotation radius needs to be corrected.


#5

I found that v0.98 uses a value of 260 for rotationRadius during triangular auto-cal, regardless of what the settings file had… I’m a little hesitant to recommend v0.99 as I haven’t tried it, but it does include a fix that uses whatever value is in GroundControl.ini for auto-cal. Before calibrating, go into Advanced Settings and make sure triangular Kinematics is chosen and change the value for rotational radius.


#6

The rotation radius for triangular kinematics is currently set to -1017.28.
I dont remember setting this value tho. Not sure why this is a negative value let me try to measure it out when i get home.

Thanks!


#7

it it’s still asking for ‘distance between sled mounting points’, it’s not doing
the triangular kinematics.


#8

That value is surely wrong, and is probably the source of your problem. If you’re using a top-mounted parallelogram linkage, try about 130. If it’s the 45-degrees version, try 260. Make sure that the version of firmware matches the version of GroundControl.


#10

The ’

That step comes before the triangular/quad choice in the earlier version of GC. I think Bar got that re-arranged for v0.99, though.


#11

@Johnny5

Have you changed the setting in Ground Control to tell it your using triangulation?

Settings -> advanced settings -> Kinematics Type

You can do measurements manually and enter them in Ground Control as to get past the issue. You click on the values to open a dialog where you can type new values.

Thank you


#12

Problem Solved!!! Thanks you for all of the responds. I changed the rotation radius for triangular kinematics to 260 and it works like charm!

Johnny


#13

Hi,
I have same issue.
I am going to try to go manually and feeding the GC with the measurements I got it manually.
The problem that I don’t know what to do next.
Can someone help to write down the required next steps in detail till the making of permanent sled?
Thanks in advance.