Maslow Home Maslow Community Garden Newsletter

Units Issue - mm, cm, and inches

To test MaslowCNC, I used MakerCAM by drawing a straight line from the origin out to 10cm. When I imported it into Maslow the line was up 100 (mm?).

Original G-code
(Generated by PartKam Version 0.05)

G21 G90 G40

(follow path 1)

G0 Z15
T0 M6
G17
M3
G0 X0 Y0
G1 Z-0.1 F800
G1 X100 Y0 F1500
G0 Z15
M5
M30

I manually edited the gcode by changing Y0 to Y-100. This moved the line down to the origin.

Edited G-code
(Generated by PartKam Version 0.05)

G21 G90 G40

(follow path 1)

G0 Z15
T0 M6
G17
M3
G0 X0 Y-100
G1 Z-0.1 F800
G1 X100 Y-100 F1500
G0 Z15
M5
M30

When I was working in inches it was even worse.

Imperial G-code
(Generated by PartKam Version 0.05)

G20 G90 G40

(follow path 1)

G0 Z0.5905511811023623
T0 M6
G17
M3
G0 X0 Y0
G1 Z-0.003937007874015749 F800
G1 X4 Y0 F59.05511811023622
G0 Z0.5905511811023623
M5
M30

the maslow can work in mm or inches, not cm

David Lang

Even when everything is in inches, the sketch is sill offset in the Y direction though.

Is there a setting that I missed somewhere?

Jog to where you want to start your cut and press “define home” That should move it onto the workspace.

3 Likes

Thanks! That works!

1 Like