User interface won't open after index.html.gz file deleted

I tried to replace the index.html.gz file and it said the file was too big. For this reason, it didn’t let me upload the file and so I got off of the maslow wifi to get internet and download a new index.html.gz file. I then realized I had originally extracted the file when I should not have and so I uploaded the compressed file and it seemed right. It started uploading just fine but froze at 70 percent for a very long time making no progress, so I disconnected and reconnected to the maslow wifi again. But now my user interface is just a blank white screen. Any suggestions?

If you are on a windows machine and have a usbc cable to connect to the maslow you can extract the zip file in the release and there is a reset bat file in there to reset to that version of the firmware.

Thanks, I have the USBC cable hooked up, but how do I communicate with the machine via the cable in order to reset the firmware?

download the from here: Release v0.79 · BarbourSmith/FluidNC · GitHub . Inside this should be instructions of what to run. I use a mac / linux and use a different process so I have not actually tried this but this seems to be the easiest for windows.

If you are a developer type, you can also use “platformio” in the checked out source code dir.

1 Like