When Updating Firmware I Get This Error

I was updating the latest firmware and GroundControl and I get this error from the Arduino IDE.

too few arguments to function ‘unsigned int fmtUnsigned(long unsigned int, char*, unsigned int, byte)’

At this point in the program: unsigned len = fmtUnsigned((unsigned long)val, buf, bufLen);

I erased the EEPROM and still get the same error.

I tried to load the firmware as of 1/15/2018 and it loads fine.

I just downloaded the release from the top of this list and compiled it (Arduino v1.8.5) and didn’t see the error. I’m on OSX, though, which platform are you using?

I just tried on an Ubuntu17.10 machine and that compiled OK.

On a WIN10 machine, I needed to run Arduino as an administrator to avoid errors.

1 Like

I’d upload a blank sketch then try it again.

Thank you

Windows 10 and I believe Arduino v1.84 so I will update Arduino v1,85 and try again.

Thank you,


1 Like

I right-clicked on the Arduino icon and used the ‘run as administrator’ choice to overcome the error. It was a permissions error if I remember correctly.


I gave it a shot at running as administrator but I still get the same error, I can load the previous version with no issues.

Just to confirm, with this error, the compile does not complete?
I’m stumped :thinking: … my last ‘hail-Mary’ attempt would be the observation that the WIN version of Arduino seems to keep separate values for the board choice for each sketch, but you’ve confirmed that this sketch is aimed at the Mega2560.
How about posting the full contents of the compiler window, there might be more info there. Maybe turn up the compiler messages preference a notch if there’s nothing interesting at first…

Try creating a new user in Windows and setting up the IDE under that user. Upload the Blink Sketch first to verify it’s happy.

Thank you

1 Like

Ya you were right, it had to do with permissions. I tried to delete directory and it wouldn’t let me do it. The ino file was set deny even the administrator. Very strange, anyways all is perfect in my world for the time being. Thanks for the help.


Great news, thanks for reporting the solution. :+1:t2:

1 Like