Problem Uploading Firmware

Hi all,

I’m super excited to get my Maslow up and running, but I’ve run into an issue when uploading the firmware. I’ve had varying error messages (which can’t be good), but the common one seems to be:

Arduino: 1.8.5 (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

c:\program files (x86)\arduino\hardware\tools\avr\bin…/lib/gcc/avr/4.9.2/…/…/…/…/avr/bin/ar.exe: unable to rename ‘core\core.a’; reason: File exists

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

This “core” file seems to be an issue for me. Maybe it’s left over from the previous version I had on my machine? Any ideas on how to get past this?

Before attempting the Firmware upload, I uninstalled an older version of IDE (when prompted) and reinstalled the latest version of Arduino IDE (1.8.5) using the Windows Installer method.

I think the next thing will be to hit the reset button on the Mega. That seems to have worked for others…

Build Info:
-Windows 10 Home x64, Version 1709
-Firmware Version 1.12
-Haven’t installed GroundControl yet (following instructions … should I?)
-Bar’s Frame built (ahead of instructions … oops)
-Z-motor kit in possession, but not installed or hooked up yet
-Will use ring kit for chain mounting, but not done yet

Try this -

Let me know what happens.

Thank you

1 Like

I think it worked!

Does that look right to you? What would it say if it failed?

1 Like

yes - Good work

I have a windows 1 file installer also.

Info here -

currently it’s 1.11 but it will get you started - if you get a mismatch error meaning firmware 1.12 and v 1.11 Ground Control you can ignore it.

We can update after.

Let me know if you decide to use it.

Edit : if it had failed it would not show “bytes uploaded”

How hard was this process for you?

Thank you

Awesome! That was super easy…

I already installed GC while you were replying, but I would have used the windows installer if I hadn’t. Also nice that I now have GroundControl 1.12

I will definitely keep this in mind for the next update! Thanks!!!


OK - Glad to see you are working. :slight_smile:

I appreciate the feed back because you are the first I know used it besides me. I posted it a while back but this is the first recorded use. I maintain several files related to installs and work arounds.

Thank you

1 Like

Cool! Glad I could be that person. Worked really well!

I’m still curious as to why I couldn’t upload the firmware using Arduino IDE though.
Any ideas?

3 possible issues

1 - you need to run as Admin right click the IDE and select run as administrator

2 - you were possibly running from a zip file.

3 - you ran into a file name length issue

These are just guesses, without collecting more info.

Thank you


I’ve not seen that problem with this version, but when I do see it, I make it “go away” by using the “Sketch/Export Compiled Binary” menu command, which stirs about behind the scenes and makes the compile magic complete. Give that a try, no need to do anything with the resulting .hex files.