Who's afraid of BigMaslow?

The 2:1 reverse purchase in the chain solves the problem of marrying the cable to the chain and also of storing enough chain for full movement - very nice. Too, the cable can change direction at the peak such that the chain tackle is fully vertical instead of slanted to match the workarea, a twist not possible with a pure chain lashup. The force on the motor will be doubled, though, in order to achieve the present force on the sled. The gearing added at the motor is to address this, yes?

1 Like

Ya know it wouldn’t be too hard to add the triangular linkage to the carriage. That might be easier than reprogramming ground control. My idea on the carriage uses the same rollers as the ring kit uses now, just twice as many. Use a flat sheet of metal and bend the sides down so it is U shaped and bolt the rollers to the sides with 2 rollers on each corner above and below the pipes. Except for the fact that you’d need more rollers and associated hardware getting that sled cnc cut and bent would probably cost about the same as the ring kit does now at least for the cutting, material might be more but machine time would probably be pretty close. And the sketch I’ve come up with still fits in the USPS box.

1 Like

Blurfl, yes, exactly.

Willja67, adding a ring for triangular math is what I’ll need to do for now- although the ring solves more problems than I need it to, if that makes sense.

1 Like

That means you have just effectively cut the resolution in half. For 2" of line movement, you only get 1" of encoder ticks.

There’s a lot of leeway. The standard setup has 8113.73 pulses per rev and 63.5mm per rev, so about .008mm per pulse. Even cut in half, that’s respectable resolution.

yeah, but HOW FAST can you go?! =)

The 1:2 is matched by a 2:1 at the motor (see the pic, a few posts up the thread). Except for some minor transmission losses, the motor “sees” the same load, and imparts the exact same movement to the sled as would the standard motor geometry.

1 Like

I did miss that part. Didn’t initially understand the text description and thought the drawing of the additional chain loop was just embellishment of the motor. Your drawing is clear, my brain just didn’t see it.

If @blurfl is correct that loss of resolution is a non issue, and it has previously been said the motors have more than enough torque; then eliminating that 2:1 reduction at the motor simplifies your setup and makes it faster for @mrfugu. Win win.

Of course the same effect can be had with fewer losses and even simpler direct attach routing by choosing a motor with lower ratio 3 stage reduction vs current 4 stage. That might also remedy the few cases of gear stripping. Fewer pulses per rev means less interrupts happening in the firmware so it will run better. Take that with a big grain of salt, I am not advocating for anything here just speculating. I do not know the factors that went into choosing the current ratio. This would definitely sacrifice available torque and could push the motor drivers over current.

My personal guess is that the spectra with chain won’t add enough benefit for most folks given the added complexity. But I would sure like to know the results of your testing @NemoChad.

so does anyone have a 12’ maslow up and running making good cuts yet? Seems like you need 14 foot long chains minimum. Unless my drawing is somehow incorrect.

I didnt’ have much luck using the chain breaking tool, so just bought a bulk roll of chain.

I can only add that the 11’ stock chain is not enough for my 11 1/2’ motor distance.
I’m not missing much but with the TLE5206 board could go extremely high with the top of my sheet.
I could not get reasonable numbers out of the calibration in 2 attempts.
Will do a third now with wiped eeprom and deleted GC.ini to exclude errors from previous releases.

correct, you’ll need to add a meter or so to each stock chain.

@Gero, just let me reiterate, to make sure I understand what you said. Here is my understanding.

You have a Maslow with a 11.5’ motor distance. You are using the TLE5206 board, which has higher capability in terms of max-current delivered to the motors. You have found that the new board has enabled you to have a Top Dead Center (excuse the engines lingo) which is higher than the stock machine. Ignoring details, at Top Dead Center, the chains are closer to horizontal. However, you have had a difficult time calibrating the machine. Is that correct?

Does your machine actually have a higher TDC, or is this just an observation, that the 5206 board enables a higher TDC?

So far I have not cut a straight line across the top to prove that it will be OK with the TLE5206 and a 10A power supply.
My observations so far:

  • The first ‘pull chain tight’ has bent my previous motor mounts, so I had to go for a rock solid mod.
  • The next 2 ‘pull chain tight’ have actually stalled the left motor and it signals that with 4 or 5 beeps :man_shrugging:
  • I can pull the 15kg sled right up to the edge of the sheet without noticing any effort and the heatsinks stay cool. (finger test and in the AC stream)
  • I choose an extreme TDC for testing and can lower with the sheet any time
  • I also can easy reduce the motor distance.
    Form what I think was happening with the stock shield and power is that I have been overloading the chips and the power supply with plenty of calibrations in the past year. I’ve fried 2 shields and the third has some strange behaviour that I think it was on the edge of giving up.

I have 2 more days to run tests but don’t really know where to start. I want the motor width so perhaps 2 calibrations with lowered sheet might show a tendency. Madgrizzle is looking into the calibration an might be onto some error that is small with the stock frame distance and might increase with going large.

1 Like

That is hilarious!

I have a theory, that the calibration becomes more “stiff” when using a high TDC. The motion sensitivity increases as the chains approach horizontal. Your measurements have to be more accurate in order to achieve a given calibration quality.

However, it may be possible that there is an error in the kinematics calculations that is highlighted by the high TDC on your setup. I appreciate the work you are doing on this, and your willingness to spend the time to highlight potential errors in the system.

what you are referring to as TDC is not a point used in the current calibration.

David Lang

All the more reason the calibration would be off.

Answering the title.
I am afraid of the big Maslow. On a 11 1/2 foot top I get a 11.6mm difference on the measuring of the motor distance. Human error > 1mm and frame flex 2mm accurately and precisely measured.
I can’t thank @madgrizzle enough for going though the code. I wish I could help but I’m missing vital information to support him from the experimental side. The software has at all times a value for each chain length and I can’t access that. I went through several calibrations today and corrected motor distance in the GC.ini but is was overwritten by the the more then 1cm wrong value later and I had to quit calibration to get the real value stored. My rotation radius is 177.8, fact. Do not even attempt to estimate that! My chains are longer then they should be? OK, allow me to enter the difference before calculating who knows what with a wrong number to start with.

1 Like

Answering the title.

I am afraid of the big Maslow. On a 11 1/2 foot top I get a 11.6mm difference
on the measuring of the motor distance. Human error > 1mm and frame flex 2mm
accurately and precisely measured.

measure with each chain separately and then calculate the chain tolerance (chain
stretch/slop) for each and enter it.

After that is done, the measurement via tape measure should match the
measurement via chain.

I can’t thank @madgrizzle enough for going though the code. I wish I could
help but I’m missing vital information to support him from the experimental
side. The software has at all times a value for each chain length and I can’t
access that. I went through several calibrations today and corrected motor
distance in the GC.ini but is was overwritten by the the more then 1cm wrong
value later and I had to quit calibration to get the real value stored. My
rotation radius is 177.8, fact. Do not even attempt to estimate that! My
chains are longer then they should be? OK, allow me to enter the difference
before calculating who knows what with a wrong number to start with.

$ commands or B commands will let you get at the current chain position (I’d
have to look at the code to find exactly what command does it)

David Lang

1 Like

During the calibration. I think it is time for software and experimental enthusiasts to have a tool just doing each step of calibration that writes the values to a text file. I can make macros but not access them during the most essential part of the machine setup. My machine is calibrated with min 2 numbers that I know are wrong.

Edit: 3rd wrong number is height of the sheet. First cal attempt it was 20cm off. I’m cheating through calibration for GC to trust me that it is 430 and not 63something. Keep in mind that it is the TLE5206 but from what I know it’s only the pins that change.

Well I’ve finally gotten my redesigned ~12’8" width machine set up a little better, and began the auto calibration which went well, however when I ask (v1.20) the machine to retract/extend the chains to attach the sled it sets them to what would only fit a default machine.

Each chain is extended 1.6m which is no help at all. It would seem that the setup measurement doesn’t take into account the machine’s dimensions, just derived. Luckily if you soldier through and hit ‘move to center’ it does move to the center of the actual machine dimensions.

Perhaps, though, this is evidence that the startup/calibration routines need to be gone through with an even finer toothed comb.

1 Like