Z-Axis Up and Down Off

I have a sled with a Meticulous setup and the z-axis up and down seems to be deficient compared to what it used to be. I plan on recalibration, however, does anyone know if the motor might be be “wearing” out?

Any suggestions on what to look for would be greatly appreciated.

I would be surprised, the Z motor doesn’t get that much use and is not under
heavy load, so I would not expect it to wear out.

check that you don’t have a cable working lose (that’s the most common cause of
Z issues)

David Lang

1 Like

Thanks for the response. I checked the travel and it is still spot on. The issue was getting gradually worse over time. I think the issue is the bungy putting down pressure on the router slide. It appears to have less pressure than it originally had. I will install a new one and see if that takes care of it.

Check the set screws /“grub” screws on the motor shaft. Those work loose over time and their loosening can cause some backlash that gets sloppy.

you can also have the orange plastic coupler wear. I even have one router where
the metal case has worn.

David Lang

OK. Have a stumper now. I verified the Z-axis is spot on with the up and down (checked at .25 inches and .5 inches). Thinking I had it figured out, I was watching web control as the Maslow was making a cut today. The g-code file I created in Easel had the overall cut at .75 inches. The deepest the cut made on this material is .66 inches.

I then tried a 1/4" deep project and it did fine. Any ideas on why the Z-axis is stopping @ .66 inches on a .75 inch expected cut (I have it set so it takes three cuts for the .75 depth)?

the Z axis has a limited amount of movement, if you don’t have the bit stick out
long enough, it hits the mechanical end of movement before it gets to where you
want it to.

can you make a short video showing the movement (from the side, looking at the
orange latch area)

David Lang

1 Like

So in webcontrol your seeing the gcode say to goto one depth, but the sled going to a different one after upgrading to a meticulous Z setup, basically like the following image correct?

If so, based on my understanding, this is why it is happening.

When the system is told to move the motors to a given position they rely on the PID tuning to get them close enough without overshoot in the available timeframe.

Using the original Z axis style the default tuning has plenty of time to get there. Using the new Z-axis with a higher gear ratio and therefore feedrate, the PID tuning isn’t able to get to the actual depth set in time.

There are two ways to correct this.

  1. lower your plunge feedrate in your CAM software until you find the fastest rate that doesn’t have the errors.

  2. Adjust the PID tuning settings for the Z Axis.
    Here is a small chart about how the settings interplay in PID tuning

    And here is a more scientific and math heavy explanation :slight_smile: Thorlabs.com - Driver PID Settings

We could really use someone with the understanding and coding skill to fix the inbuit PID tuners and add one for the Z axis.

I have this discrepancy with my z axis. The only way I have been able to reduce the error between shown z sled position and z gcode was to slow down the plunge speed. I tried to adjust PIDs with little improvement.

I even bought a new motor that did not make a difference.

Manual PID tuning is a bit of an art form, especially with differences in motors and gearing etc between builds. I’ve been messing around with it quite a bit today. My current settings are keeping me within .1mm of target, still a good deal of room for improvement though.

  • Kp Position Z-Axis - 1000

  • Ki Position Z-Axis - 2.5

  • Kd Position Z-Axis - 125

What’s ur plunge speed?

I’ve been doing the testing using G0 commands so it should be moving at whatever the systems default max would be using a -24 pitch and an overall limit of 900, without having changed the settings.cpp or using the $18 command.

When testing with G1 using different feedrates the error of margin doesn’t really vary, even going down to 5 i still see variance up to .1 ± from the set value. At any feedrate with the current settings it will sometimes manage to hit the exact value I asked for, and often lands within .02-.05mm.

OK. A little more research done. Thanks for all the replies and suggestions. It appears to be an Easel issue. I have looked at the project once again and I have the total cut depth set to .750 inches. However, I opened the g-code file with a text editor and the deepest depth shown for the z-axis is .670.

Has anyone experienced this with Easel?

1 Like

I looked at the project in Easel.