Maslow Home Maslow Community Garden Newsletter

Z motor encoder calibration after limit reach

Today yet again my Maslow lost connection to the computer for who knows what reason. This is becoming a real issue. When it does this it looses its x,y position and z position. I hit save and raise for traverse and it topped Z out at the limit of the c beam I’m using. Now my z motor is all out of wack. It operates up and down just fine, however it’s distances are really far off. For my set up I operate at -19.2 degrees. I zero out with .01mm increments. When I set the z travel to that familiar .01mm increment now it moves about a half inch. I have reset the computer reset the program unplugged everything and plugged it back in and no change. Since I own two Maslows I swapped out the sled and connected to the other z motor and it worked perfectly. How do I reset the encoder in the z motor. Please don’t tell me this motor is now garbage. I have only owned it for about two weeks. I’m hoping @bar can give me some insight here.

it’s not a matter of resetting the encoder, it’s telling the firmware how many
encoder steps per inch, this is in one of the settings menus.

this info should not be lost when you lose the connection

David Lang

I don’t think the encoder lost cal when I lost connection I think something happened when it hit its limit. The loss of connection is just what started this ball rolling. What should the steps per inch be set to? I don’t believe that’s anything I ever changed before.

Edit: wait if that’s a program parameter and nothing to do with the physical z motor then it can’t be the issue. I have one motor working fine and the other misbehaving.

there is a setting for the steps per rev of the Z encoder and there is a setting
for the pitch of the leadscrew.

‘hitting a limit’ doesn’t do anything other than stalling the motor, the encoder
does not record a position, it records movement. There is no calibration in the
encoder.

the fact that everything works with your other sled indicates that your c-beam
sled has either a different motor (requires different steps per rev) or a
different leadscrew/belt ratio (requires a different pitch setting)

This is expected with different hardware.

if you are using the same computer to run both machines, you need to keep
different groundcontrol.ini files for each machine, otherwise it will overwrite
the settings in the firmware with what’s in the groundcontrol.ini.

David Lang

This reminds me, of something I’ve been kicking around in my head. for those of us that use C Beams for our Z, or even the Meticulous Z setup, could some simple end stops be incorporated into the Maslow? Like the ones you generally find on 3D Printers and the like?

2 Likes

I see what you’re saying. However I have identical c beams and identical motors. I bought a second Maslow and started with the construction of the sled. I wanted to test the new sled so I put it on the first machine. Literally changing nothing in Parameters and no calibration since it was exact. The new sled on the old machine worked flawlessly and identically to the old sled on the old machine. … until last night.

Lost connection and backed out the bit since it was spinning in place where the connection was lost. Normally after I loose connection I set chain lengths and all that so I know it’s perfect. This time I decided to just try and have it return to center. And it did which was a suprise to me. Either way after that point I hit save and raise for traverse again ( idk I guess out of habit) decided I was going to test the encoders and this is when it hit the top. I’m guessing Bc it moved up twice from raising for traverse idk honestly. But after it hit the limit and only after did it move out of calibration.

Like I said above it moved about a half inch when it was supposed to move .01mm . I swapped out the sled again to my original one without changing anything and it operated perfectly.

Sorry if this is long or confusing , sometimes it’s hard to remember to add every step to paint the picture since I know what I mean lol.

I agree, this sounds like a hardware thing to me. Could be connector to the bad motor be loose? My guess is that for some reason the encoder signal is not getting back to the controller board. Actions -> Test Motors/Encoders could be a good way to test that.

if it’s after a connection was lost, did you try to restart the cut in the
middle of your file? if the firmware thinks you are in inch mode and GC thinks
you are in mm mode, you end up moving a lot more than you expect.

if the two sleds are identical, try switching back to the ‘bad’ one and see if
it is behaving the same now.

David Lang

1 Like