Maslow Home Maslow Community Garden Newsletter

Z axis stops reporting position on main ground control screen v1.20

Has anyone else seen this: After I used return to center on the actions page, the z axis would move (with manual and gcode instructions), but the z indicator on the main page would still show 0.00 no matter how I moved the z. It would then error if I ran a gcode file with specific z depths.

I have tried twice to reset this condition but it seems as though I have to re-calibrate the unit to get rid of this z problem. I will try switching to 1.18 version to see if the problem still persists.

Any insight into this behavior would be appreciated. I am not a novice with cnc routers and creating gcode files. I built a build_your_own_cnc_router 2’ x 4’ back in 2013 and have used it quite successfully. The Maslow is superior in price performance and this last bug is preventing me from running solely on the Maslow.

Thanks in advance for any comments/help.

Check that the z motor cable is firmly plugged in at both ends (unplug, replug).
Does the ‘Actions/TestMotors’ pass or fail? That is a good test of the encoder. If not, try swapping the z cable with one of the other motor cables to differentiate between a motor/encoder problem or an ArduinoMega problem. There is no active circuitry for the encoders on the Maslow board.

1 Like

Thank you for the reply. I might have not been clear. The z axis motor fully functions with the z axis control and moves the correct value when manually activated both up and down. It is the main page display that is frozen on 0.00. Checked the cables each time but no difference. Will run test encoders with special attention to z axis running

2 Likes

I have now run through the calbration from scratch several more times. Each time I have to set values to default in the ground control sw(I have switched back and forth from 1.20 to 1.18) with the same result. I re load the arduino code, start the ground control, and run the complete setup. Machine works great until I either return to center from the actions page or go home using the center button on grnd cntrl at upper rt.
After that the z value on grnd cntrl stays on zero(the minus sign flickers while the z is moving). The impact however is significant. I measure the z motion after and it is still accurate. But if I run gcode, it errors because it turns absolute z motion into relative z motion because every z move starts at zero(error).

This maybe something with my computer setup.

I am running an HP laptop i3 with win 7.0 professional.

Hope someone has seen this problem. I will use it without hitting return to center or move home but they may be other operation that affect the z position reporting.

Thanks for any help!!

I switched to another laptop. I am careful not to touch any of the hardware or cables and a recalibration fixes the z position comm problem. The computer is a dell i7 with windows 10 on it.

I tested it with a go to home command and the z kept communicating. I thought that I had found the problem!! I started to cut a strut for the design I am building, a part that is 5 ft. long and 7 inches wide with many cutouts. Everything worked fine for over an hour when it got to the outline cutout it made it almost all the way, and then the z froze at -0.4 depth. What is interesting is that it keeps cutting but it cut starts with a reference of -0.4 for z so the tabs started gouging immediately. If the z encoder wasn’t communication with the hardware, wouldn’t the z axis stop functioning!!?? It continues moving exactly the correct amount for each gcode instruction, but with a frozen reference from ground control it starts to accumulate errors in absolute z position.

I am hoping someone has an idea for me to try. Is there a preferred computer and win os version that is known to work?? Clearly win 10 worked better but still failed.

Any help at this point would be appreciated.

I had an instance where the encoder end of the z motor plug came partly off, so that the motor power was connected, but the encoder was not. This caused the motor to run continuously (damaged the z axis mechanism on the router) because the firmware was telling the motor to run but didn’t see the expected signal.
If you are seeing the z axis move correctly by the commanded amount and then stop where desired, but not seeing the number change on the screen, we should troubleshoot on the GroundControl end - the firmware sends its position several times a second, and GroundControl uses that info to update the screen. If you’re using the Windows Portable version, look for log.txt in the same folder that contains the .bat file. In log.txt, the lines that begin <Idle,MPos: will have the X, Y and Z values right after MPos.
Do you see the proper value for the Z axis there?

Thank you blurfl!! I will copy and archive the log files from the tests I run from now on. I also read this forum item and what I am seeing is at least partially like the experiences reporting in this topic

" Maslow Looses USB connection and all data of location etc"

I will not only check for the log file, but will make some basic changes about the usb cable quality, the AC service that the router is on,the arduino hdw, and the pc are on, and the separation of the router ac cable and the z axis motor cable(right now they hang together with less than 1/2" between them.)

I really appreciate your help, and will post working and non working logs so that it might help in the debug of these types of failures.

2 Likes

I think I have found the answer. Thanks to comments by blurfl I examined the log.txt files that were left by the operation of the maslow. I looked at the win 7 laptop trace and there were no changes in the z position in the log yet the router changed by 0.1 up and down. I then switched laptops to the win 10 and ran the unit doing the exact same move and the log.txt showed the transition up and down while the router moved. Strange that one run would work and the other did not. Well that was the key. The driver for the arduino is a com port!

I remember that I had used the win 7 laptop for some arduino boards for IO experimentation. I then remembered that of all the systems I program, arduino is the exception that it will always recompile the project even though there are no changes to the files. That was it. I downloaded the latest arduino IDE and then programmed the mega board with that computer and problem solved. Ran an 1 1/2 hour test run with no problem. I will run tests to make sure that the win 7 laptop doesn’t have a problem either - but problem solved.

Thank you so much for your patience and help. I know you knew I had something wrong, and with your help I found it. I cannot say enough good things about the maslow itself, revolutionizing the cost of large format routers, as well as the open source community that supports the progression of the code base.

Thanks again,

Howard

3 Likes

That’s great news - thanks for posting the solution!

1 Like

Hola, mi nobre es Sebastian, vivo en Argentina y tengo un Maslow!
Logre instalar con exito el sistema , incluido el eje z. Pero tengo un problema, ya que el eje z deja de informar en la pantalla del ground control la posicion. Titila el numero 0.00 hacia -0.00 pero no cambia el valor. Revise las conexiones y la primera vez que reinicie todo anduvo bien. Luego volvio a fallar y desde entonces no logro dar con la respuesta. Alguien podria indicarme alguna respuesta? Muchas gracias a todos! Saludos.

¡Hola! Lo primero que debe probar es ver si el eje z pasa la prueba en Actions -> Test Motors/Encoders

. Esto nos dirá si el controlador puede obtener una buena señal del motor.

Hola bar muchas gracias por responder.
Te cuento que pude descubrir que el extremo del cable que se une al motor tiene algun problema, ya que al presionarlo con fuerza reconoce el movimiento. No pareciera ser el cable, incluso el motor hace un ruido extraño . Ademas de esto cuando sube 1mm marca correctamente pero cuando baja marca de manera defectuosa.
Gracias nuevamente y espero puedan ayudarme mi problema.
Saludos
Sebastian

Es una buena noticia que hayas progresado. Me alegra escucharlo.

El problema es muy probablemente el motor del eje z. ¿Crees que podrías publicar una foto? Tal vez pueda detectar lo que está mal.

Hola bar te mando las.fotos del motor.

Cuando aprieto parece funcionar.se realiza la lectura en la pantalla del ground control

Gracias por tu ayuda

Saludos

EFECTIVAMENTE EL MOTOR Z FALLA.
¿QUE PODRA SER?

I think the issue is that motor. The electronics you see on the back should be covered by a black plastic part. I think that because it is missing the electronics may have been damaged. I would contact the kit supplier and see if they can send you a new motor.

Gracias por tu ayuda. Me pondre en contacto. Saludos!

¿A quién le compraste el kit? Hay varias personas vendiendo kits en este momento