15mm error while running code

Were any of those run with no dust collection at all?

All of them were with dust collection but I’m not sure if I’ve tried a dry run with the dust collection on

1 Like

It might be worth trying cutting with dust collection off. That would let us know if it’s the cutting or the dust collection that is the issue

Just to add a data point, I have done all my cutting without dust collection or a dust collection adapter and hose. I have never had the 15 mm error or the update function not being called enough error. I’ll report if that changes.


I checked my Festool hose and it appears that I do have an antistatic one:

So an antistatic hose does not fix the (my) problem :frowning_face:

1 Like

Another test: I tried grounding my sled with a copper wire:

The wire is attached to the sled with 4 self tapping screws and runs across the plexiglass cover and is wrapped around the dust collector. It is connected to mains ground using a standard mains plug (don’t worry about the blue and brown wires, they are both connected to the ground/earth pin).
I ran the same test cut that had always failed, but now it succeeded (I ran the test 4 times, router cutting and dust collection on).
BTW, I also replaced the standard CAT6 cables with longer ones (50 cm). I think the standard cables are a bit short and rigid, causing the RJ45 connectors to wiggle in their sockets when the motor arms are rotating.

With the longer cables, the connectors move a lot less and I haven’t seen anymore connection problems.


@willemx from my understanding of this setup you are using the anti-static nature of Dust Collector hose to ground the sled as well. Is that correct? It’s not connected elsewhere right?. Im a little confused by the use of the term mains ground and mains plug.

Im wondering if the material of the 3d printed dust collector attachment is insulating the static from traveling to the dust collection hose here. If I understand your setup you’re basically bypassing the dust collector attachment to make a direct connection from the hose to the sled.

I don’t have an antistatic hose on hand but I might rig something up temporarily to test this weekend before I buy one.

Maybe, but that was not my intention. I don’t know if the hose is connected to mains ground inside the Festool machine…

Yes, it is connected to mains ground via the blue and brown wires inside the white cable.

This is the mains plug at the end of the white cable. It is a 230V plug that is standard in my country (NL). The notches at the sides and the off-center hole are the ground/earth connections to which the blue and brown wires are attached. Two wires is overkill of course, but “more is more betterer” (as Dave Jones would say…)

It’s plugged in here, next to the router and Maslow plugs:

1 Like

@willemx Wow I totally missed the white cable coming off the frame and was looking for one. I feel blind after you pointed out the white cable.

Thanks for clarifying! I will try a similar approach and report back on what happens.

1 Like

Report back and well the tests did not go great. Wired up a ground wire similar to @willemx and did some cuts with and without dust collection (I have a non-anti static dust hose) and still crashes each time.

I have not grounded the encoders yet. Really hoping to be able to avoid that.

Also noticing that my two bottom cables are more loose than they previously were. Don’t think it is related but it is causing the sled to tilt when before it would not have.

Maslow-serial copy 3.log (3.7 KB)
Maslow-serial copy 2.log (15.3 KB)

1 Like
[MSG:WARN: Encoder read failure on Bottom Left]
[MSG:WARN: Bad connection on Bottom Left encoder, failed to read 1 times in the last second]

This to me looks like it could be a dusty connector. Can you try blowing those out with compressed air or computer duster and see if that fixes it?

I’m assuming you mean belts when you say cables in this post.

I don’t see you mention trying longer, less stiff, ethernet cables, like willemx mentions at the end of this post:

Would definitely be easier to try than soldering anything.

1 Like

I’ll add my experience in here. I was cutting without dust collection and thought halfway through a cut that this was a bad idea. I paused the cut and must have bumped a cable because after attaching a makeshift dust collector (my 3d printed one is in the post) I got the Encoder read failure error.

So after several disconnects and much dust removal I tried to restart the cut. No dice and then after retract and extend and another attempt using the dust collector with my cheap vac I kept getting the Update function error. Tried to retract and extend and try again a few times and then tried without the dust collector - and it’s cutting again no problems.

So for me it was definitely associated with the dust collector. Once I have the collector adapter I will try the grounding and anti static approach.

Fingers crossed

Edit: failed with the bad connection on a different axis and also telling me the update function is not being called enough. This is not great given I have a deadline. Hmmm

1 Like

Was this new failure with dust collection ON or OFF?

Thank you and everyone on this input!
Mine is still in its box. I’m still making room to design and build my frame.

1 Like

Dust collector off but I replaced the Ethernet cable that was associated with the bad connection with one I had lying around and so far so good.


I think that there are two loosely related things which result in similar error messages.

Static from a dust collector disrupts the communication is the first one. Dust in the Ethernet ports preventing them from making a good connection is the second one.

Both give encoder read failures, and they are connected in that if you cut without dust collection there is a lot more dust which leads to the second issue.

I think it would be pretty straightforward to 3d print some snap on covers for the encoder side of the cables to wrap around the ethernet ports and protect them. I may try my hand at modeling / printing some.

For the top connections and board, hmm… maybe a cone like you put on a dog when they have an injury to hide the board from dust coming up?
(and so it does not try to bite its own arms :))

1 Like

What about wrapping the self stick silicon “repair” wrap/tape around the connections and ethernet ports.
It does not have adhesive and only sticks to itself.

Can stretch it tight and wrap around top and bottom of plug/port. Should help keep ethernet plugs in tight and also dust out.

Would there be a heat issue doing this?

Anyway just thought.


Seems sound. I’m just imagining actually applying it in practice and it being potentially really annoying to find a good wrap that doesn’t interfere with the clip/contacts, possibly having to cut the tape thinner to fit between, etc.

I’d be more inclined to use the hot glue suggestion than this, because it is more readily accessible and this is a proven use (it’s used often in server environments), or to spend a few minutes in CAD and print up a clip just to avoid the potential of fighting with applying/cutting down tape for all 4 cables and potentially having to get it off of them afterwards should it not work out.


Clip would certainly be the ultimate. Just figured someone could test the tape in the meantime.
Mine still in box lol as I do not have frame built yet, I’m just trying to find out about things I need to do before I build it (improvements, etc) so I only have to do it once (hopefully).

Didn’t know about Hot Glue and servers. Interesting especially sine I am a long time computer guy (though not a server room tech lol).

1 Like