15mm Position Error While Moving Investigation

Multiple folks have reported getting the 15mm error while moving message while cutting. I’ve been trying to dig into what could be going on, but I haven’t been able to make it happen on my machine.

Since it wasn’t happening for me, @Anna and I decided to switch up the environment and see if we could make it happen somewhere else.

Anna assembled a fresh Maslow4 and we went down to our local makerspace.

Overall it was a great experience and we learned lots of things that we could improve on (better calibration if the anchors aren’t a square, better gcode preview ideas, make it less easy to click the “define home” button accidentally, etc). It’s really interesting how setting up in a new environment changes things.

But the biggest win was that we were able to get the 15mm position error to happen while running.

[MSG:WARN: Position error on Bottom Left axis exceeded 15mm while running. Error is 15.131mm Counter: 1]
[MSG:WARN: Previous error was 15.131mm]
[MSG:WARN: Position error on Bottom Left axis exceeded 15mm while running. Error is 15.179mm Counter: 2]
[MSG:WARN: Previous error was 15.179mm]
[MSG:WARN: Position error on Bottom Left axis exceeded 15mm while running. Error is 15.216mm Counter: 3]
[MSG:WARN: Previous error was 15.216mm]
[MSG:WARN: Position error on Bottom Left axis exceeded 15mm while running. Error is 15.254mm Counter: 4]
[MSG:WARN: Previous error was 15.254mm]
[MSG:WARN: Position error on Bottom Left axis exceeded 15mm while running. Error is 15.634mm Counter: 5]
[MSG:WARN: Previous error was 15.634mm]
[MSG:WARN: Position error on Bottom Left axis exceeded 15mm while running. Error is 15.691mm Counter: 6]
[MSG:WARN: Previous error was 15.691mm]

Because this machine was brand new it didn’t have a dust collection outlet and we didn’t bring our dust collector with us. As we were cutting we used this vacuum to suck up the dust around the machine occasionally:

Twice we were able to make the error happen while sucking up the dust near the machine. It didn’t happen every time we used the vacuum, but we were able to get it to happen twice.

It seems like the issue is generally related to EMF. My hunch is that it was an issue with static build up on the dust collector hose because in both cases where we had it happen it was when the vacuum hose touched the machine or was near the encoder cables. Static in dust collector hoses is also a known issue for this kind of thing:

It’s also possible that the issue is some sort of noise on the electrical system. The maker space wiring isn’t the greatest and the lights dim pretty dramatically when the shop vac comes on…that being said the issue didn’t seem to come from the vacuum turning on as much as when the vacuum hose touched (or was very close to) the machine.

We will keep investigating next week, but I figured I would throw that idea out here in the meantime.


This makes so much sense to me. When I have had issues i was running with the the shop vac attached, the router, vacuum and maslow on the same power strip and the power cord for maslow and router zip tied together.

1 Like

I haven’t used dust collection with mine yet, but I’ve seen this failure happen. Using the same power strip for both router and board, though.


In addition to the issues mentioned above, if the output of the power supply for the Maslow is isolated from ground (these kinds of power suppplies often are like this) then it is floating relative to earth ground. As ithe Maslow slides over the wood and especially as air flows through the plastic dust collector attachment, the Maslow could build up a huge static charge which would then occasionally discharge to the grounded router or something else. This could really upset things.

1 Like

I have been reading the linked article. I was about to try to do some test cutting today and I will see how it goes but if it does not go well I’ll try to figure out how to ground my vacuum hose. The router does not have a ground either so I wonder if that contributes when static builds up and it just travels to the ground of the maslow?

1 Like

Any ungrounded device, termed “floating, … will also emit a 6-8 foot electric field (in theory, emanating to infinity) from their power cord and the powered device itself, even when the power switch is off

So while out in the garage looking for another outlet to plug my extension cord to and put the router and vacuum in, both the router and my vacuum do not have three prong grounded plugs. I assume this means they are “floating”. The only way around that would be to remove the cord they have and replace it with a grounded one, right? connecting ground to the metal chassis or …? Is there a simpler solution to this if that is causing the issue?

1 Like

Maybe, but that sounds like a lot of work and I’m not really sure that’s the real issue. My understanding (which is hazy) is that the real issue is more likely the dust and air in the vacuum hose rubbing against the sides.

Those things act a bit like rubbing a balloon on your head and build up a big static electricity charge.

My dust collector came with a hose specifically to prevent that kinda like this:

But apparently you can get the same effect by running a wire down the hose? I’m not 100% clear on what the other side of that wire should be connected to


Me either 100% but the way I understood it from reading the hole I’ve dived down in the last few hours, to ground… which in the case of my shopvac is floating so I’m not sure it will help a lot

1 Like

The router and vac, even though they have two prong plugs, still have a neutral wire, which is supposed to be tied to ground back at the breaker box. This is sometimes wired backwards at the panel (dangerous!) and even in the best of situations there is some impedance in the long runs of wire, preventing the ground from being good enough for electrical noise reduction. It will for the most part keep these two devices from developing an AC floating voltage that would be unsafe, though higher frequency electrical noise may not get drained away.

I would not try to add a ground to any metal parts inside the router or vac, for fear of compromising the double insulation that keeps them safe to use.

What you might do is run a bare copper wire inside the vacuum hose and tie that to ground. This is commonly done when people use pvc pipe for fixed dust collection systems. People run the bare wire through the pipe and have it exit through small holes they seal with RTV. The most important part to do this to is the dust collector adapter mounted to the Maslow, and in fact this might be sufficient by itself. Can you 3D print conductive plastic?

1 Like

And I should have added, the bare copper wire is tied to earth ground.


I have a spool of conductive filament from many years ago I was experimenting with. I can certainly try to print the shroud with it, then attach it with one long bolt grounded to earth ground (assuming the filament is still good). Probably not a good general solution but I can try it for sure.

OK, new clue:

I have been having successful cuts all day on my testing, until… I started a job and it seemed like it wasn’t cutting super smooth, so on the next long move where the bit was not in the material, I took the hose of the vacuum off, vacuumed out the problem area to take a look, then put the hose back in the maslow. When it got to the place for its next cut, it plunged, ran through a few moves, then suddenly went off on its own again, wandering down the board… no error messages at all. I hit the power, but it did ruin this round of cutting. also I think I was too aggressive on my cuts, which may have caused some slipping and was the reason for the jagged cutting.

Given the issue happened right after I reconnected the vacuum, I’m fairly convinced this is related. I’ll try some of the suggestions here and will try again another day. So far just leftover scraps have been my victims, but I don’t have any left so it will start getting more expensive to test :slight_smile:


Out of curiosity has anyone in the UK had this issue as I’m pretty sure our routers all have grounding as standard. If the lack of issue in the UK is true, then it could be a grounding issue on the router

I’ve had this happen repeatedly and I wasn’t using a dust collector at the time. So I don’t think it’s the static coming from the dust collector that’s causing this issue


Same here, though I would hazard it could only make things worse.


@bar, is there any chance that the stray static electricity is interacting with
the non-grounded pin on the encoders to confuse the system?

I’m thinking of just enough charge building up to trigger it to reverse
momentarily (until the charge dissipates) and throw everything off.

David Lang


I had this static problem with my “older” Maslow and my z-axis cable. My Z axis would go bonkers at random times, so I wrapped some aluminum foil tape (used for HVAC vent joints, but worked as a cheap “sheild” for me) around roughly 24" of the vac hose, starting at the dust collector toward the vac AND used some dry lube silicone on the (wooden) sled and never had a problem with EMF interference since.

The cabinet shops I’ve worked in all had grounding in their dust collection AND on table saws. Exploding sawdust collection bin is an actual thing, had a cabinet shop burn down in my town due to this exact problem.

The moisture content in the wood, humidity (dry air), and friction all play a role too. Maybe if you “mist” the wood with a fabric softner/water mix, it “might” help with the static buildup?

NOT a scientist, just a simple carpenter spit-ballin’ some ideas…

These might be helpful links:
—> Static electricity what it is how to control remove eliminate static shock
—> static electric charge on wood - FineWoodworking
—> Static charge on wood


I am in Colorado, and our relative humidity year-round is very low, so I’d not be surprised if static in some form is more severe for me than those in the pacific northwest where its much more humid.


I was unable to get the issue to happen today which is unfortunate because it means that I couldn’t do solid testing to see what changes made it better. I did create

Which I think should help (assuming my assumptions about what is going on are correct). If anyone who is seeing the issue would be willing to test that and report back I would be grateful.


I pulled Maslow-Main and built and uploaded it. I see your change for 200000 on Wire.begin, so I have that change for sure. the branch is clean and merged from upstream.

After hanging the machine and applying tension, I noted that it was doing the diagonal “squeeze” move and I saw a bit of flex on lower-left/upper right squeezes. I looked at my anchors during this and they seemed to not be flexing so I’m not sure where the flex was coming from.

Once tension was applied, I sent it to my job home, and my lower belts both ended up very slack when I moved and when it got to home. They were not last time I did this a few days back. Then I tried to jog up and right diagonally, and the bottom left belt started spewing out a lot. I’m not sure what happened here. should I recalibrate? Were there other recent changes that would have caused this? I am going to upload the actual binaries from the release just to make doubly sure I don’t have anything odd in my codebase…

1 Like