15mm error while running code

this has been pretty frustrating. I’ve had 4 cuts in a row that end up stopping due to a 15mm position error. I’ve recalibrated countless times but continue to get this error each time. what can I do?

MSG:ERR: Posit


ion error on Bottom Right axis exceeded 15mm while running. Halting. Error is -19.646mm]
[MSG:ERR: Emergency stop! Stopping all motors]
[MSG:WARN: The machine will not respond until turned off and back on again]
[MSG:INFO: Reset during file job at line: 493]
[MSG:ERR: Position error > 15mm while running. E-Stop triggered.]
No heartbeat from machine in 10 seconds. Please check connection.

1 Like

@ronlawrence3 is seeing the exact same thing so it seems like there is a bug. We’re working to track down what it is.

When that issue happens you aren’t seeing anything weird in the belt tension or anything like that right? IE you aren’t actually having a 15mm error?

I’m having some play in the tensioning cable but I don’t think it’s 3/4” worth

1 Like

I would only expect to see that error (other than a bug) when the cables are too tight, so if you have some slack then I think it’s unlikely to be a real issue and it’s likely a bug.

Okay, thank you so much for your help Bar. Is there another software version I could try that may not have that issue to get me by for the time being?

1 Like

so i ran a dry run of the file I’ve been trying to cut and it did 100% perfect. then i loaded my material and started it up again but it got about 4 minutes in and failed again. could it be due to sawdust? Thickness of material? just trying to think of things that could cause it to happen in case it helps

1 Like

I’m trying to think of things too.

Is it repeatable that it works with the router off, but runs into issues with the router on?

I haven’t had the chance to do another dry run but I plan to tonight. I’ll let you know how it goes

1 Like

Just did another dry run and it got all the way through it again.

From posts I’ve seen several people are having kinda similar issues. I have a small list of things I’m going to try to see if any of them help.

  • Faster RPM
  • Dust collection
  • New bit
  • Slower Speed
  • Perform calibration with a full sheet of plywood on it already

I’ll let you know how they end up going

1 Like

try a dry run with the router spinning, but no bit in it.

David Lang


Does ESP32 in M4 have a temp sensor or thermal throttling? ESP32 can run hot and the airstream from the router that blows on it is also hot. Maybe some of our mystery issues aren’t related to software but caused by thermals.

And running the router spinning with no bit will be very useful data to collect.

so far I’ve only had the chance to run 3 tests

  • Dry run no material
  • Dry run with material
  • Router on but not actually cutting material

all of these successfully finished the complete Gcode so I’m thinking the best option is to increase the router speed so that there is less tension on the tensioning cords

1 Like

I just made some changes last week in 0.74.2 which should help prevent this issue too which might be worth trying

I just updated to that version and now when i try to connect to the machine it connects for a couple seconds but then says there is no heartbeat from the machine

Update: read through some other forums and realized it was a bad connection with the top left encoder. unplugged it and blew the dust out and then it started working again. ( i think this shows it may be the dust that is causing my issues. luckily my dust collector attachment just came in the mail)

1 Like

So I installed the dust collector part and I’m still getting lots of errors where it is having difficulty getting readings from the encoder. I’ve pulled the cat5 cables out and blown any dust off and I still get maybe 1-2 minutes into a job before I have more issues

I’m hoping to have time to play around with it tomorrow. My next plan is to try a couple different shallower cuts. Maybe I was just being too aggressive with 1/4” at 100 IPM
What depth cuts are y’all successfully getting?

Same issue just occurred for me as well:

Job is set to cut 8 pieces; It completed the first 3 and then failed on the 4th.
3/4" plywood, stepdown of 0.3", feedrate of 50in/min.
Yes, I know this is aggressive, but I’m only getting burn marks when I plunge up/down for the tabs, and I’m aiming to resolve this by changing tabs to be triangular.
Just before the job failed, I noticed that 2 of the lagging cables were loose, as if the slack wasn’t being picked up when it was moving.

Before starting the job, I did pay attention and marked where 0,0 was on the plywood, so I guess I could restart from that position. Or spend some time re-generating code that skips the first 3 pieces… any other suggestions?

GC:G3 G54 G17 G20 G90 G94 M3 M9 T0 F1270 S5000]
[MSG:ERR: Position error on Top Left axis exceeded 15mm while running. Halting. Error is 15.016mm]
[MSG:ERR: Emergency stop! Stopping all motors]
[MSG:WARN: The machine will not respond until turned off and back on again]
[MSG:INFO: Reset during file job at line: 732]
[MSG:ERR: Position error > 15mm while running. E-Stop triggered.]

MSG:ERR: Emergency stop. Update function not being called enough.1002ms since last call]
[MSG:ERR: Position error on Bottom Left axis exceeded 15mm while running. Halting. Error is -15.107mm]

I have been trying everything i can think of for the past couple days and I’m about out of ideas.
done several dry tests with success but once i try to actually cut the material it keeps failing. each time I’ve noticed that the bottom 2 motors aren’t being pulled as tight as i would have expected. ill try to upload the video i took of how loose they are.

1 Like

I’m in your same boat. It seems like it must be related to EMI and if I ever get the time I will try to ground my dust collection hose, move my ferrite collar up to near the router, and whatever else I can think of to reduce interference and let everyone know if any of that has an impact.

So I just had a possibly happy accident. I forgot to zero the z axis and so it thought 0 was to cut all the way through the material. It did not struggle at all. I’d almost say it did even better cutting a large amount out than just a 1/4” I canceled it right after it got through the one piece and have yet to try a full depth cut on purpose but intend to give it a shot tomorrow

I looked it up and for the bit I’m using (O flute) the closest settings I can get on this machine to match the recommended chipload are 3/4” cut at 100 FPM and 18,000 rpm (setting 2 on the dewalt)

1 Like