Maslow Home Maslow Community Garden Newsletter

2D Pocket Random Toolpath Movements (SOLVED)

Fusion newb, here.
Since the z-axis is painfully slow, I’m trying to eliminate unnecessary z moves. Can someone please help me understand why the bit is picking up in these spots below (green lines)? On the “linking” tab of the pocket properties I have “keep tool down” checked and the “maximum stay-down distance” set longer than the part itself, which helped, but didn’t eliminate these. I also do not have Lead-In or Lead-Out.
Basically, I don’t want the bit to pick up at all in this pocket since there isn’t a reason to. It also starts milling on one side of the pocket, picks up, moves to the other side, then starts milling again. Very inefficient. I have also used “Preserve order” and “Entry Positions”, which help but it still seems somewhat random.
Exported project is attached. Thanks.New Football v4.f3d (575.2 KB)

1 Like

what’s your safe height?

image

Its the minimum. I’ve been messing with this all afternoon. Doesn’t seem to matter.

try checking: “use morphed spiral machining”

1 Like

SOLUTION: “use morphed spiral machining” check box on the “passes” tab of the 2D pocket properties made the somewhat random paths perfectly smooth and predictable and no unnecessary z-axis moves.
Thats the ticket! Thank you, @Jatt!!

2 Likes

Hi @Jatt,
As I started cutting this, I noticed how very little the bit was stepping over, which you can see in the toolpath with “morphed spiral” checked. Obviously this adds a lot of time to the job, which is what I was trying to improve originally by eliminating z-axis moves (I need to cut a bunch of these).

The maximum stepover is set to just under the bit diameter but it seems to be overridden with “morphed spiral” checked. I also noticed the check box “allow stepover cusps” but that didn’t change anything.

The original toolpath shows machine time of ~3 minutes, which I believe should be longer since the z-axis feed rates I put into Fusion don’t reflect the actual speed of the stock z. The “morphed” toolpath machine time is ~5 minutes. Ideally the original toolpath, that allows a much larger stepover, would be used since it is less passes, but I still can’t figure out how to get rid of the random z moves. Some of those are green, which should mean they are a lead in/out but they are going in the z direction…and I have lead in/out unchecked.

If the “morphed” option would stay true to the stepover setting, or the standard toolpath didn’t do all the randomness, that would be great! Any other ideas?

The morphed spiral does a cleaner cut by following the contour of the pocket, and stepover is not adjustable. You could possibly use the original gcode and just manually remove the unneeded Z moves, if it’s not trying to do rapid movements between the lead in / lead out points. Are you using the maslow post processor with fusion?

That’s what I was going to do…but…but! :sob:

I do have “preserve rapid movements” selected in linking (see above) but lead-in/out is unchecked.

Yes

you may want to take a look at the gcode optimizers that are available, here are
a few links (I haven’t tried any of them)

https://xyzbots.com:4000/gcode-optimizer/


http://www.cuteminds.com/en/il-software/freeware-per-pcb/78-gcode-path-optimizer

David Lang
k