Maslow Home Maslow Community Garden Newsletter

Strange toolpaths with Fusion 360

I posted this on the Fusion 360 forums, but haven’t gotten any responses, so figured maybe I would try here. I have a small part that I am trying to generate toolpath. But looking at it I am getting a bunch more z movement than is optimal. It even stops and goes the other directions some sides. I am brand new to F360 so am trying to figure out how to fix this. Basically it is a simple shape, but instead of just going around it, every layer it stops 3 times and goes to another part. Any ideas?

https://a360.co/2Kvr0Dn

Looks like your step down is your tool diameter by default… Not sure.

Still learning myself…

When you set up your 2D contour, I have been unchecking the Ramp box on the linking tab, and on Passes change from Climb milling to Conventional. Climb milling will make some extra noise, like trying to push stock backward through a table saw.:grimacing:

On Pocket operations i change the default Ramp from Helix to a plunge, also.

1 Like

I think you may have lead-in and ramps enabled, like @Jamtek mentioned. The last tab and second-to-last tabs should have those check boxes available.

Agree with Jacob on the lead in/in and ramps. The red line you see at the angle is the ramp, green is a small arc into the cut.

As for stopping and going to another cut I have a couple questions. How did you create the path for the part you are showing? Was it one setup with steps down or was each step down a different setup?

One thing to try to make the code so that it is one long path vs. retracting at the end of the cut and the plunging again is the "Linking/Keep Tool Down. This should keep the tool down and complete the cut without retracing and plunging at each step.

Lastly did you try to simulate the machine in Fusion. Select the tool path(s) to simulate Cam/Actions/Simulate. This will give a good visual of what is going on.

If you uncheck the Ramp box:
image
On the Linking tab:
image

I think you should get the plunge only path you’re looking for.

The reversals can be caused by the Both Ways option in Passes:
image

2 Likes

Thanks for the ideas guys, but it turned out it was I had 2 contours selected, and was getting confused. But yeah there are a lot of options, and will eventually get a good set working.