Belt issues and firmware updating difficulties. Please help

Hello All,
Let me start out by saying I am really looking forward to starting to cut, I have assembled the Maslow but I am stuck there.
I have been able to setup the wifi connection and even retract the belts. But now I cannot extend any of the belts 2 of the belt encoders show a yellow and green light (TR&BR) and the other 2 (TL&BL)show only green on the cards. I have swapped the ethernet cables to other channels and the board led display the same lights. FluidNC does readout they are retracted and gives an offset for each one.
I have tried to update the firmware using Fluidterm and get a reply of no serial port found. So I have been unsuccess with updating. I have even tried to update the maslow.yaml file using the the Wifi connection and that errors (but I don’t remember the error code. Sorry)
Final question for now. Does the cooling fan run continuously or does it cycle on/off as need? Because my fan has never turned on even when I try to extend the belts.
I am sure I will have more questions as I progress coding is not my area, but I can cam and have been running CNC machines for years.

Thanks for your help.

The good news is that this is totally normal. The green light is power, the yellow light will turn on and off as the encoder rotates.

It cycles on and off as needed, but it should be on during the extending the belts process.

It sounds to me like the issue might be in getting the belts to start extending. Are you using the rocking motion to get them started? It can be a little tricky at first.

This video shows what the process looks like: