Board connected, motors don't respond, unable to upload to board. Motors running on their own

Hi there!
I mounted my Maslow cnc by eastbaysource a few months ago, and besides some struggles with movement and callibration, it worked fine, using Groundcontrol 1.26. Recently, however, I tried to make some changes to the firmware and loading them through arduinoIDE, Itried this several times. Noticing that my changes did not work, I tried going back to the original firmware 1.26.

At first it worked normally, however one day Iturned the machine on and the left sprocket started rotating by itself, no command made by me. This happened every time I connected the board. Now, everytime I open Groundcontrol 1.26 or webcontrol I get the errors “the sled is not keeping up” and “unable to find valid machine position”. “Tests motors and enconders” isn’t working either. I tried using “Wipe settings and positions” and “Wipe EEPROM” but then I got the error message “EEPROM read fail”.

Captura de pantalla 2022-10-13 121236

When trying to upload any firmware to the board through arduinoIDE the uploading process never ends and this is the information given (see attched file) .

I tried following this post:

to try and find any process that was stopping Arduino IDE from connecting to the board, unsuccessfuly, as shown on the image bleow.

Another thing i noticed was that the sproce are moving by themselves and the error indicators keep appearing,all over and over again, as seen on the image below.

On a side note. I tried grading the firmware throgh webcontrol, unsuccesfully.
Thanks for reading, I tried to be as detailed as possible. I’m quite desperate since I don’t know what else I could do.

motors spinning by themselves is most often from the cable coming out of the plug slightly so it isn’t well seated and the encoder is not signaling it is stopped. Have you run the basic motor test in the webcontrol action menu? do they all pass?

1 Like

Hi Orob! thanks fot the response

Motors disconnected, still message from board.

Run test,fail:


Sorry, my instructions were unclear. Please verify all connections are fully connected and then run the test. A failure you described could be caused by a bad connection. Removing all connections will cause them to fail as you have demonstrated.

In the video i was showing the blue bar of Webcontrol mooving without any conection to the motors. For the capture of the failed motor test i had alredy connected the motos to the board.

It appears that you may have flashed your controller with the wrong firmware for your board, so the encoders are not reading correctly. When the motors are to move and the encoders are not connected, it will move forever since the feedback from the encoder thinks it is going the wrong direction. The safety fix here is that blue bar only allows so much deviation before it shuts it down. Can you post a picture of the shield and the version of firmware you are using? Did you flash it with the webcontrol 1.26? if so, you need to go to eastbay source and use their version or 1.28. I forget which one they are using. I have a version you could use that should work I can upload a little later if you like.

1 Like

Thanks! the problem was solved installing the 3.0 firmware from eastbaysource