Calibrating - Cut Dimensions

I’m trying to finish the calibration on my machine. I’ve run the test cut and entered the measurements. After I enter the last measurement, Ground Control freezes because a dialog with a long, long list of errors is running in the background.
Those measurements are:

And since I don’t know what else to push at this point, I press “Enter Values” again. And then I get this dialog that pumps out thousands of this error and maybe a couple others for a few minutes:

And finally, it stops with this error message:

“Machine parameters could not be determined.”

Any idea what’s going on here and/or what I might be doing wrong?

Wow, never seen that. Is this with FW/GC 1.26 from the releases or the current developer version?
Only thing that sticks out is that i would try a 0.25 instead of .25, but that’s not it i guess.

Would you upload your grondcontrol.ini found in your {username} folder?

Kind regards, Gero

I am using the release version for both firmware and Ground Control.

I’ll test the 0.25 vs .25 shortly and report back. If that doesn’t work, I’ll upload the groundcontrol.ini file


1 Like

Adding the 0 for the bit size didn’t make a difference. Here is the contents of the groundcontrol.ini file:
groundcontrol[1].ini (1.5 KB)
[Computed Settings]
distperrot = 63.5
kpposmain = 1300
kiposmain = 0
kdposmain = 34
propweightmain = 1
kpposz = 1300
kiposz = 0
kdposz = 34
propweightz = 1
kpvmain = 5
kivmain = 0
kdvmain = 0.28
kpvz = 5
kivz = 0
kdvz = 0.28
chainoversprocketcomputed = 2
fpwmcomputed = 3
kinematicstypecomputed = 2

[Maslow Settings]
bedheight = 1219.2
openfile = 
motoroffsety = 400.05
sledwidth = 310
zaxissafeheight = 10
bufferon = 0
bedwidth = 2438.4
comport = COM3
macro1_title = Macro 1
sledheight = 139
macro2 = 
macro1 = 
zaxis = 1
sledcg = 79
macro2_title = Macro 2
colorscheme = Light
zdistperrot = 3.17
motorspacingx = 3424.08

[Advanced Settings]
rotationradius = 170.0
chainextendlength = 1650
kiv = 0
gearteeth = 10
spindleautomate = None
kdvz = 0.28
chainsagcorrection = 0
chainpitch = 6.35
chainlength = 3360
propweightz = 1
zencodersteps = 7560.0
maxfeedrate = 800
enablepospidvalues = 0
rightchaintolerance = 0
enablevpidvalues = 0
maxtouchprobeplungedistance = 0.0
kpvz = 5
kdposz = 34
chainoversprocket = Bottom
kpposz = 1300
fpwm = 490Hz
kdpos = 34
encodersteps = 8113.73
truncate = 0
homex = 0.0
homey = 0.0
kinematicstype = Triangular
kipos = 0
kdv = 0.28
kiposz = 0
digits = 4
kppos = 1300
kpv = 5
propweight = 1
positionerrorlimit = 2.0
kivz = 0
leftchaintolerance = 0

[Ground Control Settings]
zoomout = pagedown
centercanvasonresize = 0
viewscale = .45
zoomin = pageup
validextensions = .nc, .ngc, .text, .gcode

[Background Settings]
backgroundfile = 
manualreg = []

Ran through the dimensions in the calibration again and received the same error message. I did get a picture of a message in Ground Control after the error. It read:
“The machine was not able to be calibrated. Please ensure the work area dimensions are correct and try again.”

I tried the manual calibration as suggested by @bar here: Machine not able to be calibrated

This moved me through the process, but I guess my question now is are these correct if my “home” is not defined as the center of the backer board? Or is this something I redefine with new cuts?

How is the rotation radius 170? What triangular kit are you using? The ring?
Not near to the solution, just asking out of curiosity.

The software measuring the motor distance goes way off if you extend the top beam from 10 - 12 ft.
Flex in the top beam is only one of the reasons.

I hope you can get lucky by replacing the values in the .ini with what you measure by hand.

Please report back either way, solved or not.

Kind regards, Gero

Hmm. It shouldn’t be. I measured it today and it’s close to 114mm. I’m wondering if when I started and restarted the calibration process several times it didn’t remember the values I had put in for it the first time around…?

How wide is your top bar?
it says chain length is approx 11 feet, but motor spacing is approx 11.2 feet.

chainlength = 3360
motorspacingx = 3424.08


1 Like

So I just finished getting my system set up and was running through final calibration today. I had input measurements out to 3 decimal places (using mm in my case) and it gave that same message on save (Enter Values) every time. I had to remove everything past the decimal to get it to save out properly. Could it perhaps be a field constraint bug in the software thats not allowing decimals in those fields?

1 Like

Oh wow, something is off because I’m pretty sure I’m using a 10’ top bar. I’ll have to double check the length. If I remember correctly, I both measured the distance between motors with the calibration process and manually measured it with a tape measure. I’ll get to the bottom of this in the next few days. This likely explains some of the weirdness I was seeing with some test cuts.

I’m far from an expert on this but if that is the case, I would consider that a concerning bug because of the loss of accuracy. :thinking:

1 Like

Just remeasured my top bar. It is 120" in total. The center of each sprocket is 1.5" from each end. So distance between motors should 3009.9mm. I’ll have to adjust that. Thanks @jatt for checking my math!

1 Like