Constant Calibration Interruptions

I re-built my frame using the new assembly guide but am unable to calibrate the machine AT ALL.

Every time I get to the chain length calibration I only get a mm of movement and then a warning popup that says the sled is not moving as expected, press stop to clear the error. If you press stop and then re-feed the chain it just does the same thing again.

I tried removing the GroundControl folder and cloning the repo, then setting up everything by hand and every time I get to the chain calibration it does this. Of course it doesn’t know where the sled is, thats the whole point of the calibration…

I can’t jog or do anything that requires movement, says “Unable to find machine position for chain lengths -2.31,0.00 Please set the chains to a knowen length (Actions -> Set chain lengths)” but when I use the chain length calibrator I get the first popup about sled movement.

My chains are entered correctly under advanced settings -> chain length.


The right hand chain feeds out fine. The left always says the sled is moving wrong. I can get positive values in the chain length popup “Unable to fine valid machine position for 19.73, 1648.71”. When I do the motor test the sled moves the same way as the red circle does in groundcontrol so I dont know why its saying the sled is not matching the movements when it clearly is.

I’m un sure of the motor issue however on the setting side. Your settings should be saved in the Groundcontrol.ini file. In 1.11 under actions -> Advanced -> Reset settings to defaults. Should make a back up of that file and remove it if I understood @bar. Close GC and reopen it it will crate an new empty file file automatically.

Thank you

Even with settings to default the first thing that pops up on a new connection is “Unable to calculate machine position” Needed the press stop before the chain calibration job buttons would work. I then went to Calibration (as the ini file was wiped) and it let me feed about 1M of chain from the left sprocket before it said the sled was no keeping up again. There is no motor stop button on the calibration screen so I have to back out and reset everything every time.

Spent about 5 hours today trying every combination of things and every type of calibration screen makes the error popup. I even updated the FW and GroundControl to the latest versions available.

do the motors all respond to testing?

Are you doing the calibration before you try any other movement?

are you using a triangulation kit of some sort? or the original brackets?


Motors respond correctly to testing, The sled moves the same as the red circle and they say they pass.

Sometimes upon boot I do not get the “can not calculate machine position” error and I can jog around and everything moves like it should, usually pretty close to the distance requested.

No triangulation kit, just the brackets. I have tried the calibration in both methods as well as with the chains on top and bottom of the sprockets.

I deleted the ini, used the interface to reset to defaults, deleted the folder and re-cloned the ground control app. I also wiped the eeprom on the arduino and updated to the latest firmware. I get “can not calculate machine position” and/or “Sled not moving as expected” errors at some point of the calibration process.

I have tried Manual Calibration, Calibrate, Chain Length - Automatic. I tried Chain Length - Manual and it says you must manually enter the chain length in an error box.

I checked the ini and nothing is a weird number, no negatives and eveything is very close to default (as it should be, I just built the frame as per the instructions today)

Ok, without a triangulation kit you can’t do chains on the bottom, and you can’t
do the triangular calibration.

All you can do is the quadralateral top mode. If you are getting the “can not
calculate machine position” error, that means that the dimensions the system has
been told do not compute with the chain lenths that have been fed out.

So you need to re-measure everything (bracket spacing, distance from the
brackets to the bit, distance to the CG of the sled) and make sure that the arms
and motor mounts are solid (a 2x4 between the wings would be a very good idea)

1 Like

Where are the chain lengths fed out value stored? I delete the ini settings file and when I open groundcontrol I get an immediate machine position error. It doesn’t matter if I choose triangulation or not, it always errors out.

The ini files with settings at default gives the same error, even before I press any buttons, as soon as it connects for the controller.

Is there a command to dump the controller settings, maybe something went horribly wrong in the update.

you need to also clear the eeprom in the arduino, there are various instructions
out there for completely wiping the arduino.

This is a new feature in 1.12 and I’m sorry to hear it’s giving you trouble, that’s good feedback for us to tweak it to make it better for the release on Wednesday.

I think I know what’s going on. That feature is intended to detect a stalled motor and halt the machine if it ever gets more than 2mm away from it’s target position. If for some reason (like a switch to a new frame) the machine is WAY far away from where it should be that error could keep triggering and prevent it from moving to the right location.

In the meantime I recommend uisng the latest stable version of the firmware and Ground Control which is version 1.11

Another possibility is that the popup is right…have you changed the “Max Feed Rate” setting?

Ill try v1.11 this week if I get time. The sled not following error makes no sence when you are calibrating the chains so maybe that error check routine should be skipped if any of the calibration windows are open?

As for the feed rate I haven’t got that far yet. Still the stock 700.

1 Like

@iceblu3710 I’ve been trying to track this one down. Had you made changes to either of these settings before seeing the issue?

No changes at all.

I took down my old temp/prototyping frame and built the new standard one shown in the assembly guide. I cloned the latest FW and GC github repos on a new shop laptop. Opened up GC and did the motor test a few times to make sure everything was moving in the correct directions. I then pressed Calibrate and got the errors immediately upon trying to calibrate the distance between motors using the chain. I then tried all the other calibration methods and get the error on all chain related matters.

I ran the Arduino eeprom_clear script and when I boot GC it says it can not calculate the machine position with chain lengths 0.00, 0.00 so I know the arduino eeprom was wiped, but this message pops up immediately on every GC boot.

I changed to the GC v1.11 branch this morning but have not had time to try and calibrate again.

1 Like


The good news is that I’m pretty certain that 1.11 will make the issue go away, but that doesn’t explain to me why it is going on.

One more thing to try is to adjust the position error limit under advanced settings:

This is the threshold at which you will see that error popup. Making it something huge like 200 should make the issue go away…not a solution but the work around might give us more information to find out what is going on

Can I load GroundControl with a verbose or logging switch to help generate some sequencing info?

I will hopefully get back out Friday nite to try these ideas out.

I scrapped a few hours together this weekend and V1.11 indeed solved the problem.



I am getting this error message to.

What’s the best way to update Ground Control? I extracted the files and it made a new folder for 1.12
Then I created a shortcut for launch ground control on my desk top.
When I launched GC I got the error message too

I also updated the firmware just prior to this.

Any info would be greatly appreciated.


Are you seeing that error message consistently when using the machine or just once when starting up?

Constantly and almost at the same place, give or take a inch or soIMG_3562IMG_3563

I saw a post about going back to version 1.11 I did that, I got a message that firmware and GC was different. But it allowed the GC 1.11 to load. But I even got the same message, the screen shots above are from version 1.11.

Which makes me think that I am not doing the update correctly?

try setting the max feed rate lower, your machine may be running slower because
the sled is heavy or the power supply isn’t putting out quite enough ummph