Unable to finish Calibration

Hey Maslow Team,
Having some issues with the sending the test cut values to the arduino. Have some pictures of the errors I am getting. I am on a windows 10 laptop using the portable version of ground control 1.10. I have not yet added the Z-axis. My temp sled was hitting the bottom when making the lower cuts so my measurements might be a little off. I am wondering if I might just give it a shot and cut a temp-final sled and have better results with that.
First time going through the measurements I used inches. I then converted to mm to see if that might have been the issue. Any help is appreciated.

Oh also I do not know if it contributes to the issue or not but my left motor when rotating CW or CCW for the calibrations almost seems to wiggle back and forth and not really changing every time when clicking on 1deg or .1 deg. After a few clicks it would seem to move.

how dothemotorsrespondif you do a motor test?

Do you recall the measurements you entered in? The algorithm looks like it’s finding a negative chain sag value is required to meet your measurements, but this isn’t allowed and hence the algorithm fails.

Would you happen to be able to snap a few pictures of your setup during the calibration?

1 Like

Both L and R motors passed Z failed but I have not installed that yet so that makes since. I do have it off in the settings

My first photo shows the measurements.
Cut 1 to 3 was 1957mm
Cut 3 to 4 was 1954mm
Cut 5 to top was 274mm
And I am using a 1/4 in bit

The other calibration values are here.

I went ahead and tried to cut out a sled and got an oblong sled. Don’t know if that would help with the debugging.


1 Like

Thanks, I missed those the first time!

Those look a little suspicious. Would you be able to snap some pictures of your sled, possibly when it’s doing some cuts?

1 Like

I’ll try to get some. What do you mean suspicious? Is there something your looking for?

I’m wondering if your linkage kit is functioning properly. Typically this scenario can only happen from position-related issues, such as:

  • Linkage kit malfunction
  • Incorrect chain lengths
  • Sync error between GC and Firmware

Not an exhaustive list by any means. :wink:

Why did you pick 127 mm for the rotational radius guess?

Also, post some pics of your frame and your sled. That may help us figure it out.

I tried my best to measure it from the tip to the point the chains are attached to the ring. I got about 5in. It is not exact but that was the best measurement I got.

pardon my photography skills.

The chains for the left motor are not Ideal. I will fix that soon. But I do not think that is the issue.

This last one might be the issue. The ring is hitting the handle on the side so I will adjust that and try again. Just something that I was not able to notice since I have not cut much yet. It was not hitting during the calibration test cut but I will try calibrating again.

1 Like

that cut looks like chain skip

Hey, we are having the same issue in the woodshop at school. But we are using Apple, and it wont do the test cut part of the calibration. I am a old construction worker turned middle school teacher and am learning all this myself for the first time.

1 Like

@bar, since all ring kits are the same, what should the actual rotationalRadius be under ideal circumstances? The instructions say 140mm but @fill6251 measured it to be more like 127mm. I wonder if the problem is that this value is “too far off” for the software to converge upon a solution.

1 Like

I believe it should be right around 138mm for the radius.

@Tanana are you using Ground Control 1.10? There was an issue related to this fixed in 1.10

I thought that was just PC. I will check immediately!

You can always find the latest version here: https://github.com/MaslowCNC/GroundControl/releases

Took some fiddling, but got it to move anyway. It went to the top of the frame before i could be shut off. Then Port 3 ceased to function. Ordering another arduino shield, but cant figure out why it seems to have smoked down the first one.


The two parameters which matter are the spacing between the motors and the rotation radius for where the chains attach. The vertical motor offset could also have an effect. Do all of those numbers look reasonable in the settings?

It has been a busy week and I have just now gotten a chance to look at it again. I took apart my sled and measured the distance across the ring and the ring rollers I got 278mm which half of that is 139mm. The issue now is that I do not see the rotational radius option in the calibration menu anymore. I only see it at the “does this look good” page. and I can not change the value.

1 Like

Never mind it is set after that screen.

1 Like