Maslow Home Maslow Community Garden Newsletter

Calibration Bug or Unclear Instructions with Measuring Motor Spacing in v1.17 for macOS

Some context: I just received the kit and finished building this out up to where I need to calibrate it so I can CNC the final sled.

I have hit a problem with Measuring the Motor Spacing where the measurement length between the motors do not line up with what I had expected.

First problem I encountered is that I assume that entering a number in the “Dist(MM):” will manually set the distance between the motors and let me proceed to the next step. After I typed my distance in millimeters, the only options given on the top buttons are “Back”, “Skip”, and “Quit”. See screenshot.

Since the next steps gave me Motor Distance Numbers that didn’t match with what I manually gave it, I tried to follow the instructions as given.

Which is my second problem: How do I measure the chain length after following the instructions? I hooked the left chain to the left and right motor sprockets as instructed, then pressed the “Pull Chain Tight and Measure” button. But I had to use the “Stop Motors” button because the L Bracket for the left motor was pulling up and becoming crooked. How do I proceed from there? All I still see on the top buttons are “Back”, “Skip”, and “Quit”.

Is the software suppose to detect when the chain is taut and measure itself? If not, where do I enter my measurements?

I hope my explanation is clear enough. I feel like I can really taste the first cutout with this!

This step is going to measure the distance by paying out chain from one motor until you can hook the end over the other sprocket in the manner shown. The value it is asking for is how much chain to extend to get you “nearly there” when you click “Extend”. When it stops moving, you estimate how much more is needed and enter that, and so on. Once you’ve got the end hooked over the far sprocket as per the picture, the “Pull Tight and Measure” button will pull tension on the chain and record the amount of chain used. You can give the “Pull…” button more than one poke if the first one doesn’t get the chain tight.
Keep going, you’re almost there!

So to rephrase things, so I understand it better, after following the onscreen instructions and then finally using the “Pull Chain Tight and Measure” button, this command will measure out the distance of the motors within the software, and automatically go to the next step?

That’s right, when you align the left sprocket to 12 o’clock and hang the chain end on it, it sets an internal counter to zero. As you extend (or retract) the chain it keeps track, and when the “Pull Tight” finishes, it knows how much chain was used.

Yes, but if your motor mount bends, i expect he still sees movement and won’t stop pulling. Are the mounts screwed into the top beam with all the possible screws?

1 Like

I’m also on MacOS and using the Bars Bolt Together design for my frame and I had the same issue. I ended up adding 2 more screws to the back of each motor mount to prevent it from rotating. This solved my issue and allowed me to proceed to the next step. However, I am having an issue at the next step.

Thank you for confirming! This was exactly what I needed and was able to proceed to the next step. @Walt_Moorhouse mentioned additional screws, which I ended up using as well on the “Bee’s 80/60 Frame Design”.

2 Likes

Good move! I’ve been bitten by the ‘twisted motor’ myself, it caused much mystery and bad accuracy…