Calibration Problem... Left Motor Command not responding during "get Sprocket to 12 O'clock"

(Skip all this if you want to cut to The Problem below…
Over the last couple of days I have been moving towards making the sled on my new Maslow, first calibrating the temporary sled, doing some test circles, and then cleaning up the build so the chains, wires, and dust collection are all in order.

When I ran the Sled file the first time, the Z axis/Ridgid router hung up so that the cut only went .4 inchs deep… I found the problem (Dust Shield pushed in too far, keeping the router from going all the way down), and reset the system back at the beginning and let her rip again over the same path…

All is fine, and then about 3/4 of the way through the router stops moving, and the screen says “Lost USB Connection”… During the run my laptop goes to sleep, and I had to log back on, and I am thinking this is why progress stopped/connection lost. Got back to ground control, but I couldn’t get the cut routine to restart. Shut down Ground Control, and when I came back the home position is off center at a different place than normal start up or the Sled file start spot. Pressing the Home button raises the sled straight up, but not to home. So, I figure I need to re-calibrate…

The Problem

Stepping through the Cal process, I reach the “Get the Sprocket to 12 O’clock” and I cannot adjust the left motor… no response to any of the left motor adjustment commands. Running the Test Motors/Encoder, all motors passed (several times). Switched connections to the motors, and now the left motor works on the “Right” commands, but the right motor does not on the “Left” commands. When the Left command are given, the connected motor makes a buzzing/throbbing sound, but no movement.

What’s up?


Note… I am using the latest Firmware/Software, V 1.10

1 Like

When you switched connections, you were switching at the board end rather than the motor end of the cables, right? If so we can assume that both cables are good and are fully seated in their motor connector. And do I understand correctly that with the cables switched the ‘Test Motors’ still passes? With the cables in their proper places, do both motors run when you use the up/down arrows on the main GC screen?

Having the computer go to sleep or into low-power mode is a real problem. Since the laptop supplies power to the Arduino, if the laptop shuts off the USB port then the Arduino loses power and loses it’s place. That would be why when you brought it all back up, the present location was lost altogether and the machine was in need of a chain calibration. Using a USB hub with an external power supply could keep the Arduino from losing power. With the Arduino powered up but the laptop asleep, the Arduino would finish whatever gcode line it was working on, bookmark its location coordinates and wait for the next line of gcode. When you wake up the laptop and GC connects again, cutting wont ‘just recommence’, but the Arduino will correctly report the sled position and recalibration won’t be necessary.

First of all, thanks for responding bright and early on this holiday morning. Happy Easter!

Yes, I switched the cables at the board, and fiddled with all the connections. Yes, the test motors function works in all cases, with all motors passing. When the failure occurred, I don’t think anything worked at Ground Control. I noted the line where the system hung, and tried re-starting at that line… but I really don’t know if I did that properly. After I closed and restarted GC, Home was lost, in an odd spot to the right of center, not where the sled was. Pushed the Home button, and the sled went straight up about 18” and stopped. At this point, I figured I was screwed, and Recal would be the next step. I have not tried any of the other sled moving functions since restarting. Being a newbie at Maslow with a lot of computer experience, (and little programming savvy), it seemed like the laptop stayed awake while running Ground Control, but not so. I will go into the Win 10 world and try to shut off all the power saving stuff. I shut everything off last night, hoping when I turn it on today it might work. I will report on that in about 30 minutes.

Thanks again!


So, went back out and fired up the system to see if the sled direction controls worked in GC… Had to reattach the sled, it was pretty high, so I set 12 inches and sent it to the left… it went straight down. Thought I made a mistake, so pushed up, but it still went down. No matter what direx I tried, it kept going down, but hey, both motors were working. So I took off the sled and went back to Calibration… per a post I found from Bar last year, I tried the Set Chain Length - Atomatic. Not exactly automatic, but the 12 O’clock controls worked, the lengths were set, and with the sled back on, it seemed to center. I could not make a clean exit from the Set Chain Length routine… when pressing Finish, nothing happened. so I Quit it, and was warned that the chains might not be right.
GC’s file loading button was grayed out and would not work, so I shut it down and restarted. Loaded the Sled file, and it was positioned where I had left it when this particular adventure began, The machine’s sled was centered on the board, so I pressed Home, and the sled went to the sledfile starting position. Entered the G code line where it had stopped, and started the operation with the router turned off… the bit landed 1/4" to the left of one of the brick holes! Moved the work piece to line up the hole, and I am about ready to give it another whirl… What could possibly go wrong?!? If this works, maybe I should buy a lottery ticket!

A clean exit from a calibration with reasonable numbers to compare is essential, from my view.
I fear that your best option is to face a new calibration from start.
Before you consider that, can you upload a copy of your groundcontrol.ini here?
It should be in your ‘home’ folder.
Can you use the internet from your workshop (Maslow)?

@Dustcloud, I had to go through the calibration process four times to finally get all the motors moving in the correct direction. At one point I was trying to adjust the Z height and the sled kept moving up. Almost cracked the Arduino/Maslow board (I’ve since moved it to a safer location). Try calibration once more all the way.

I’d come and help if you’re near Houston.


So, 2 minutes into the attempt to salvage the first cut proved a waste of time, as the cut woa off probably 1/2 inch. So I went ahead and changed position and ran the file again…


Looks pretty good… the “circle” is 18" high x 17 29/32" wide. Hopefully we can improve that in fine tuning.

Gero, I too am uncomfortable with the poor finish on the Auto Chain Length routine. My next step is to get on the new sled and go through the complete calibration. If there is a fly in the code ointment, would love to know now. I can upload the file, but I do not see an .ini file in the folder… what is the name of the file you want. Would I need to Zip it for upload?



The file @Gero is looking for is ‘groundcontrol.ini’, it can be found in your home folder. If you have trouble finding it, let us know which operating system you’re using as the path is different for the various systems. You won’t need to zip it, you should be able to drag copy it when you make a post in the thread.

1 Like

@Gero, you could add to the list of ‘reality-checks’ I’ve started here.


That looks really good. It’s a big light showing the end of the tunnel.
Thanks for the pictures.
So nothing wrong with your system from what I can tell.
Only need to get the calibration through clean. From what I see now is, that instead of a complete new calibration (wipe EEPROM and delete groundcontrol.ini), share the settings you have now.
Perhaps just a new calibration without clearing anything would do the job. It’s worth a try.


Please help me out. How will you mount the ring kit, or what file are you using to cut the sled (source).
This drill operations (red) confuse me.

Need --> + sleep.
18 Inch = 457.2 mm
17 29/32 Inch = 454.819 mm
diff = 0.09375 Inch = 2.381 mm
is not good enough for you. Let’s get that better.

This behavior happens when the machine has horribly bad dimensions set (i.e.
calibration is very wrong)

First, here is the groundcontrol.ini file…

groundcontrol.ini (1.3 KB)

Gero, regarding your question about the sled, this file is for the sled made for the ring,and is linked from the latest “Cut the Sled” doc on page 10. I converted it to G-Code using Easel. The holes in question are used to line up the ring brackets… here is a photo of the newly assembled sled…


Everything seems to be working OK now… Last night at this time, not so much… I cannot explain why the motor controls were screwed up… I reset the computer and and reloaded GC several times last night. This AM, at Gero’s request, I tried moving the sled around using the GC keypad, and, although the direction was incorrect, all the motors worked. One thing I have noticed. If there is no Home set, the sled performs weirdly. Since Home was lost, and I did not set it (only really learned how to do that today), perhaps that was the cause of some of the trouble.

I will calibrate from where I stand now, unless you think otherwise.

Thanks All!!!


Went through the calibration routine, got through all the steps, said it was looking good, posted a review of all the settings, then congratulated me for a successful calibration. But then when pushing the Finish box, nothing happens. Pushed it several times to no avail. Then tried Skip… nope. Quit works, but warns me the quitting early may result in errors… Here is the GC .ini file… looks to me like all the new values are there, at least what I can recognize. I manually measured the distance between the motors, and my measurement was 4mm longer. Went with my measurement.

groundcontrol_4-2.ini (1.3 KB)

Happy Monday!


I am making a list of calibration related issues to look into today and this is on there. I will find out why the finish button wasn’t closing the popup