Maslow Home Maslow Community Garden Newsletter

My Maslow is destroyed, please help me figure out what happened

I put this thing together, and all was fine. I had to use a different computer so installed ground control and figured that it had to be calibrated with the new computer. Whenever I try to calibrate the chain would fall off when it is calibrating the chain length. It came up with a number so I just went with it after the 4th try.

When I was trying to get the 12:00 position on the motors, I would press 1deg CCW and it would move the motor CW, but 5 deg CCW would move it CCW… Some thing was off there, but on the last calibration it functioned properly.

I have 8 holes that I need cut in a 3/4" plywood. I put them in makercad and exported the gcode. After the second hole it started to cut some goofy lines, so I hit stop and then the home button. It went close to home and then stopped and then just kept on going until the ring bent out of shape, and I don’t know what would have happened if I didn’t unplug it. The ring is destroyed. Anyone know what went wrong?



20190804_172054
20190804_172430
20190804_172502

1 Like

While I don’t have any concrete ideas as to what caused this behavior, there are a couple of things that stand out to me.

  1. In your screencap of GroundControl, the list of commands in the bottom right says that it loaded the sled position at “134.45, 226.36”, then later at “121.47, 248.15”, yet your units are in inches. This took me a minute to see, as I run my machine in mm and those numbers are pretty typical. But if the machine is set to inches, both of those sets of coordinates are very far off the bed. Also, from this list, it looks like Ground Control keeps loosing connection with the machine (hence the position loaded at: several times)

  2. When you were running the calibration, you’re having trouble with the motors going a consistent direction of rotation. This could be a bug, but I’m assuming not because that function has been working since the earliest days of the machine.

What I’m seeing is that there is some issue with communication here, probably between Ground Control and the machine. I would first try a different USB cable without any extension cable on it. Those extension cables have shown to cause issues in the past.

It would be a lot easier to diagnose this problem if you uploaded Ground Control’s log file. It should be in your computer’s documents folder, but I could be wrong. That will help show what G code had been sent to the machine during the entire session that this issue occurred in.

Thanks. If the units were an issue I think that it would have shown up as an issue when the holes were cut out. I can’t imagine it just changed units mid routine. I never paid attention to units at all. I assumed that since it fit on the workspace in ground control that it would run properly. I am attaching the log.

I will get a new ring and then take a video of the calibration and see if I can replicate the reverse behavior.

I am using the USB cable that came with it, without any extension. I’ll get a new cable as well.

log.txt (1.8 MB)

Erik

Here is the gcode that I used. cupholes.nc (123.0 KB)

regarding the disconnection, when it all went sideways I pulled the wires out to minimize the damage and that message was the result.

I see what you are saying, it is like the machine was stuck in inches and the home button was in millimeters.

Looking through the code, I’m now not sure. It’s handling the unit conversion in the background. When it did that position loaded at line, it lists 134.45, and the next line, it lists that coordinate at 5.29. If you divide 134.45 by 25.4, you get 5.29.

Furthermore, your program has a G20 in the startup block, so it’s telling the machine to interpret all the coordinates in inches. I did a search for G21 (to switch the coordinates to millimeters), and it’s nowhere in the code. So it looks like your code is good.

I’d still look to see if you’re getting some interference in your motor cables. Other than that, someone more familiar with the electronics than I would be a much better help figuring out why your machine is running so erratically.

Meant to say this in my first post, but whenever the machine is doing something and you’re not sure why, press the red stop button in GC. I know it can be scary to loose progress on a program, but it really helps avoid damage like this. I froze one time running a CNC mill when a round part broke free of the fixture and wiped out the tool touch off probe next to it on the table. Had I hit the e-stop even a second earlier, I could have prevented that costly mistake.

If you’re handy with wiring, setting up an actual E-stop button would be a good idea as well. Would basically do the same thing as unplugging, but it’s much easier to hit the big red button than run around and unplug the machine.

Woah! That is pretty wild. My guess is that one of the motor cables is somehow loose or the encoder signal is not getting back to the controller. If the controller thinks the motor is not spinning, but it is actually moving then the controller can’t accurately know the machine’s position.

The large separation between the actual position and the target position in your screenshot is an indication that something is up with one of the encoder signals.

image

The fact that the circles cut properly until the error makes me think that one of the cables came loose at that point.

There should be a software stop that powers off the motors and gives a warning about one of the motors not keeping up with the target position in this case, did you see anything like that pop up?

2 Likes

EDIT2: nevermind. I can see from your log you are using v1.26.

@Blazman what GC and FW versions are you using?

I’m now having an issue with the black and red crosshairs not following each other and the machine is not stopping; no errors. For me, the black crosshairs follow the bit but the red crosshairs “get stuck”. I have unplugged and plugged in my cables. I have not had any issues with a run-away sled, and I’m using custom firmware based on v1.26, but just thought I’d ask. I have not had this issue with the custom firmware I’m using when it was in sync with v1.25 GC/FW.

1 Like

I have experienced this many times. This is a software bug that has been around since at least v1.25 (what I started with). I don’t know if it is in GC or FW.

1 Like

During the “pull-tight” step? My chain would slip off the right sprocket (only three links on the sprocket) so now I carefully clamp the first link to the sprocket, making sure not to affect the chain as it comes off the sprocket.

I see you were getting the "
Message: Unable to find valid machine position for chain lengths 0.00, 0.00 . Please set the chains to a known length (Actions -> Set Chain Lengths)" error. Looking through your log, it looks like that might have popped up after calibration?

Also, you may not be getting the position error since it is set for 2000 mm (78 inches). I thought the default used to be 2 mm?
$42=2000.00000000 (position error alarm limit, mm)

1 Like

@bar All of the motor cables are fully seated.

On a previous cut the bit was in the material and it started to cut some phantom line about .5" into the material and then it gave me a message that the sled could not keep up.

IN total I have made 4 cuts with this thing and 2 have gone haywire. Apart from the the ring which has to be replaced, which parts should I replace?

-Erik

@WoodCutter4 Yes during the pull tight and measure the chain pops off, it falls off the left side though. Each time it throws the chain it gives a similar number for the length, within 50mm . I tried to tape the chain with duct tape but that does not work.

The unable to find valid machine positions was popping up during some of the failed calibration attempts.

1 Like

I would start with just the ring. I don’t think this is a hardware issue, I think this is an issue with a setting, probably in calibration. When you have a working ring we can walk you through calibration in a way that checks to make sure all is well.

Just to be safe, I would recommend running the Test Motors/Encoders function to see that everything is looking good on the electronics side.

3 Likes

I don’t get this one… does it kick the chain under tension (violently) or gently unwind the last bit of chain until it falls off the sprocket? the chain should have enough purchase on the left sprocket to not pop off.

1 Like

I would consider one of these two options to replace the ring:

@Blazman, Sorry that this happened to you. I had a similar thing happen. I ran calibration, which was successful, and then cut a small test piece which was almost correct. I then pressed the Home button which is when the sled started moving up instead of going down (which I expected it to do). I think Groundcontrol worked out a wrong home position and I had not set the home position manually. It kept going up and at the moment it approached the top edge I stopped it. I think it would have kept going like yours did. I then manually moved it to center, using the arrow buttons, and set home position. After which is returned to home successfully.

One thing I noticed with calibration is that it has problems if you ever go back a step and then continue forwards. Now if I mess up on calibration I always start it from the beginning again. After calibration I move the sled manually to center it on the board and set the home position.

Did you set the home position at any point after calibration and before you pressed the home button?

3 Likes

Now having thought about it, I have as well. Calibration is a bear. I usually just wipe everything and start over if there are any hiccups, like chains falling off etc. The times I have not started over and just hoped for the best are when things like this have happened. In my case, it was moving down and to the left. I guess it depends on what it thinks each chain length is.

3 Likes

Sorry for a late reply, I been out of town for a few days.
Got your email, no need to pay us anything, we will mail you a replacement ring and brackets for free, hopefully you will be back on track soon.
Gab

5 Likes

when you have successfully calibrated once, mark the links that are at the top
of the sprockets as you finish (just before the ‘move to home’ step)[1]

that way when something goes wrong, instead of having to do the entire
calibration again, you just need to set the sprockets to 12 o’clock and hang the
marked links on them, not go through the entire calibration again

David Lang

[1] by default this is 1651mm on each side, you can change this value in your
settings, just keep it a multiple of 6.35mm and you can have it be whatever you
want.

2 Likes

@JohnC it kicks the chain violently under tension.