Maslow Home Maslow Community Garden Newsletter

Calibration Problem? Skewed Cuts

I desperately need some good help. I bought my Maslow CNC about six weeks ago and still haven’t had a successful piece cut (I did have a successful “engraving” that was supposed to be a cut, but that Z-axis problem is resolved).

I tried to attach two videos explaining the results and my current problem. However, apparently, that’s not allowed so I’m breaking this into two parts:

Specs and Troubleshooting Efforts:

  1. I have 1.26 of both Firmware and Ground Control
  2. I’m using a Macbook Pro
  3. I’m using a Rigid Router with bungee cords to keep the Z-Axis happy
  4. I’m using Inkscape for the vector images and Easel to create the g-code
  5. I’ve calibrated the machine probably a half-dozen times at least and manually calibrated it using a shortcut and link from a super helpful guy on this forum (Madgrizzle, I think).

I’ve been frequenting these forums for solutions on many occasions, but I haven’t learned to read g-code yet. I seriously doubt that is the problem, however.

Results of First Several Cuts

I created two identical pieces in Inkscape. They look identical in Easel. They look identical in Ground Control. However, when the Maslow cut them, one was at least 1/4" (probably closer to 3/8") longer on one edge. In other words, when overlayed one on top of the other, one piece was significantly longer on one edge than the other one. The other parts of the piece were fairly close to the same size.

Three pieces were created from the same template so all three pieces should have had one part that was identical. On Inkscape, they all measure within 1/32 of an inch or 1/1000 of an inch discrepancy. None of the pieces were the same size when Maslow cut them. The biggest to the smallest versions were about 3/8" different.

Another piece was supposed to be square on all four corners of the piece. Not only did it come out trapezoidal instead of squared, one side that was supposed to be a centered, symmetrical-curve turned out to be lopsided - far to one side as part of the trapezoidal skew.

Lastly, when I tried to print a second, similar pattern, I set everything up in Ground Control so that the new cuts wouldn’t overlap the old cuts. When I “Set Zero” for home position, everything looked perfect (just like the first one had looked perfect on Ground Control). There was at least twelve inches of free space at the top of the board. However, when it started to cut, it started cutting about twelve inches higher than Ground Control was showing on the screen (I measured the size of the board/cutting-surface on my screen and estimated that measurement). Ultimately, I had to stop the cut because it was going off of the cutting surface.

Does anyone have any ideas what may be wrong at this point in time? Frankly, I’m about ready to demand a refund from Maslow. This is getting ridiculous. It shouldn’t take this much coding expertise to get a machine to work. None of my four degrees or twelve books that I’ve written have prepared me for this type of challenge … Any help is greatly appreciated.

for your calibration: Did you measure the distance of motors manually or went always through the calibration “full” procedure?

I let the machine measure the distance between the motors. After a full calibration, I marked the chain segments with finger nail polish so a manual calibration would be possible later - thanks to Madrizzle for that tip and the link to show me how. The numbers all seem to match the original numbers still so that calibration should still be good, right?

Other thoughts?

1 Like
  1. Doublecheck the distance of motors with a tape measure by measuring from the left outer straight edge of the left motor to the outer straight edge of the right motor and deduct 40mm. This will give you confirmation, whether the distance measured by the calibration procedutre is accurate or not … in case not, enter the value manually measured in the settings and always skip the distance measure in case you redo calibration. In case you skip any of the steps of the calibration procedure, always the value from settings will be used …
  2. Whats the angle of your frame?
  3. Whats the weight of your sled?
1 Like

What do you mean exactly when you say ‘Set Zero’ for home position. What specifically are you doing?

Post some pictures of the cuts, post the gcode used for them, and post the contents of your groundcontrol.ini file (I’m not sure where its stored on a mac). That might help us figure out what’s going on.

Measurements are good.
The angle of the frame? We’re using the new, square frame where the chains make a Z-shape from the motor to the middle of the frame and back to where they are nailed into the frame.
Weight of the sled? We are using a MakerMade prefab sled. Do you mean the weight with the router?

Thanks.

When you mess with the settings on the Z-Axis, there is a “Set Zero” button to set the depth of the bit when it is touching the board. That is what I was referring to as “home” position.

I’ll grab some pictures later. I did a couple short videos but the forum disallows them apparently. Tons easier to explain via video …

thanks

I tend to upload videos to youtube and then just share a link here. Seems to work well enough.

Okay - I can do that. They aren’t very flattering for Maslow so I was trying to keep them more private, but they probably won’t get any outside views anyway.

I’ll say considering that there are MANY maslows that do work I can’t imagine there’s a fatal flaw in the design that would prevent you from getting up and running. I suspect its just a calibration issue… almost all issues as you describe are a result of (and don’t take this the wrong way) misunderstanding the calibration directions… which admittedly may not be the clearest in the first place.

Yes - this is my biggest complaint with the Maslow: inadequate instructions and inadequate direction to helpful resources. Then, because the instructions are so incomplete, you have to go online where people give conflicting advice so you have to try everything to see what works. Originally, I had a bad Arduino, which made it impossible to get up and running well, either. The videos are still uploading onto YouTube.

I couldn’t confirm your statement … When we’ve got our Maslow we followed all instructions received from MakerMade and got it running right away … Maybe we had been lucky, I don’t know! However, as statet by @madgrizzle problems are usually connected to the calibration … and there are a few things, which really requires some accuracy, such as …

  1. Balance of the sled: when you move your sled to the bottom edge, does the sled tilt or has the remaining sled full contact to your work board? if its lifting you need to reduce the weight of the counterweights/bricks ,… What we did: We used each 1,25kg cast iron weights (bodybuilding), as this is shifting the COG!
    Test as well what happens, when you move the sled to the upper edge. Does the remaining part of the sled still have full contact?
  2. When you finished the 1. exercise, doublecheck whether the chains are parallel to the work board! If not, move the brackets on the ring up or down until the chain is parallel.
  3. As you statet, “the measuremenst are good” this assumes you know the distance of motors, so there will be no need to do this step und you can skip this when you are doing a new calibration, which is mandatory, after you have finalized no. 1 & 2 … as per our experience, skipping the motor distance step, the whole calibration takes 5 minutes ony!

Belive me, MASLOW is working and come on, its a tool for the ambicious hobbiest and not intended for the commercial use, at least not until you add some more things and off course some more funds, what we did,! We are making CNC cutting for people who want to have i.e. chairs , tables etc … similar to opendesk.cc.

2 Likes

makermade has a fairly detailed set of instructions that come along with it. You can find it on their website. I haven’t used them so I can’t vouch for it. My only concern would be if you use the instructions and you are NOT putting the chain slack along the top-beam… but if you are using their kit (and therefore instructions) you probably are putting the slack along the top-beam.

yep, @madgrizzle … here’s the link to the instruction archive of MakerMade: https://www.makermadecnc.com/category/build-and-setup/ for your convenience @Flaming_WoodWorks

1 Like

We used MakerMade’s instructions to set things up - AFTER - we first used online instructions (in other words, we received a hard copy of instructions from MakerMade when they replaced our defective arduino). However, we were not told that the instructions we were given were not for the frame option we were directed to from links MakerMade has on their website. We haven’t found hardly anything based upon the square frame model we opted to build. That’s made instructions confusing.

I’m not sure I’m understanding your question about having the slack along the top beam - there is one beam across the top where the bungee cords and chains attach to the motor - that is the only option for the square frame model we’re using.

Here is the link to the video: https://youtu.be/UhzXGZyUqqI

We’ll give this a try. I did notice that when the sled was at the bottom of the board, it started tilting some. That was not however during a cut. Skewed cuts were also in the middle of the board.

Thanks.

The original design had the slack of the chain running vertically… Can you post pictures of your frame? I’m not familiar with what you refer to as “square frame” model.

These are the instructions my partner used to build the frame. He’s been uber meticulous to follow their instructions and we’ve additionally made certain everything is level. I’ll look for a picture with the chain set up as well.

I linked to the spot of the video that shows what the chains look like when set up. Ours look cleaner/tighter, but the basic idea is identical. https://youtu.be/zcKQeTfn5cQ?t=687