Calibration Process with Spindle start

I’ve added spindle on/off control to my setup but the calibration process where test cuts are made seems to assume manual start. Can you add the spindle on command to that process during some future update?

And now it looks like spindle start may have been broken in the latest firmware (1.12). Anyone else having this issue?

I believe that it is added. Let’s assume that the issue is actually that 1.12 broke something. I know that 1.12 added support for active low relays, the solution might be as simple as going into settings and turning on the option again or selecting the correct relay type

Spindle automation option is set to 1.

I don’t have mine automated so I’m not speaking from experiance, but what does option 1 mean?

And now I see a number of options when I click on Spindle Automation so I don’t really know what “1” means. When this job is done running I’ll try changing it and let you know what happens.

1 Like

:crossed_fingers: that will fix it.

Here’s the thread with all the info from the folks who know what they are talking about:

Ok, the value of “1” has no meaning. The setting should reflect the options in plain text. Once I set it to “relay high” it worked fine. Transition issue between releases…


Excellent! Thanks for the update that it worked :+1:

1 Like

The servo=1 option was supposed to be something where a servo is activate that actually flips a physical switch. I see it in the code, but haven’t seen anyone actually use this.

New issues today… “sled not keeping up…” when running a job. Another weird issue is that the GC panel representation for top and bottom no longer matches reality. I’m trying to cut some large arced panels for a theater set and my initial cuts are close to the top. When the sled does its initial move to the top, it actually ran off of the sheet after I had restarted from a “sled not keeping up” alarm. That’s when I noticed that the graphics didnt match the position. I had to reset the position of my home start to what looked like it was hanging almost 2" below the panel but in reality was an inch above the bottom. I suspect this is a calibration issue of some kind, but not sure where to start. Would the fact that I’m running close to the top of the panel cause the sled alarm??

Well, the sled alarm is happening continuously now as I’m trying to cut within 10" of the right side. I stopped that job and went back to a new cut. Seems the positioning issue is getting worse. See the attached snapshot. The router is sitting 5" in from the left and 1.5" up from the bottom of the sheet and this is now set as home. I did restart GC but no change. V1.12 of GC and firmware.

It could, the alarm is caused when the motors are unable to move as fast as software is commanding them to go. At the top of the board the strain on the motors is the highest. The fact that you are seeing the same issue over on edge of the board makes me think something else is going on.

Are the driver chips getting proper cooling? They will reduce the power to the motors to protect themselves if they get too hot which could cause this behavior

I’ll check the board, but it is mounted behind my frame so I don’t normally monitor that. When I’ve checked in the past, they were always cool. And this was the start of a job, so they didn’t have a lot of time to heat up….


Just wanted to revisit this issue. The spindle on command does seem to be missing from the calibration. Just re-ran calibration after changing my shield board and the motor never started. Had to replug and do it manually. After calibration checked the settings and spindle start is set to high. My macro in Ground Control still works for on/off. Maybe check that again??