Help! Alarm Notification: The sled is not keeping up with it's expected position

Hi. I can’t figure out why I’m getting this notification and its happening every time I try to move the motors, sled attached or not. I’ve just starting using the machine and the first few parts were made without a hitch. Now I can’t even finish calibrating the chain length without this error popping up. When I run a motor test all motors pass. Any advice to how to resolve this would be much appreciated.

The simple solution is that we can just turn off the notification, but that doesn’t help to figure out what the root cause is.

Are you seeing the notification immediately every time you try to move the motors? (probably a false alarm) Or does the notification show up after a while when the motors are moving?

1 Like

Thanks for the quick reply! I did see that I can turn the notification off in the settings but I’d like to know why it’s happening to be sure this isn’t a symptom of a bigger problem. The timing as to when I get the alarm differs between motors. It seems as if when the left motor moves one direction it happen almost immediately. With the right motor it happens after a minuet or so.

1 Like

Great, me too. I would much rather find the root cause.

What PCB version do you have? I fixed a bug with PCB 1.2 this week that could be related (although I would expect to only be in one motor)

Does reducing the maximum feed rate under advanced settings make the issue go away?

1 Like

Currently running 1.2, updated firmware and GC. I did have the max feed rate set above the default at 1000. I brought it down to 800 and the left motor triggered the error when setting the chain length. I brought it down to 500 and no error msg! Any clue as to what’s going on? I’m happy to run at 500 for now but after working at the higher rate it’s kinda like watching the grass grow.

I started seeing the alarm today as well. I have been trying to calibrate all day to get rid of oblong circles. I deleted the ini and started from scratch… This only started in the afternoon when I tried the triangular test cut, the machine homes and then starts it way up to the top left corner and only gets a few inches… It looks to only happen when the work load is on the left motor… I tried throttling the feed rate to 500, but when traveling, I still see a velocity of 31.5"

This sounds like exactly the bug I just fixed. With PCB version 1.2 the left motor was not being driven at full power.

Would you give the firmware linked here a test and let me know if it helps?

1 Like

I will give it a shot and report back shortly.

1 Like

That appears to have solved it. I put the sled to home and then went to the top left corner without issue… I will start the calibration process again and see if I can get through the test cut. On a side note, when I try to load the benchmark gcode in 1.12, I get a not found error… Where can I grab this from?

1 Like

That is great news!!

That fix will be a part of version 1.13 when it comes out on Wednesday so everyone will get the same benefit.

While pretty annoying this warning for when the sled lags behind is helping us catch and fix all sorts of other issues.

I’ll look into why that file isn’t loading. Are you using one of the downloaded versions of Ground Control or running it from the source? Windows or Mac?

Until I figure out what’s going on, here’s the file:

Calibration Benchmark (632 Bytes)

1 Like

I got this same message, it did let me calibrate, but when I ran the additional test pattern I got the error in the same spot on the right side of my work area.

Another user suggested downloading version 1.11 of both ground control and firmware. This fixed the issue for me

I am running an older laptop so I have been blaming issues on that and Kiri:Moto

Happy to report that I cut some large sized parts with Ver 1.11 today and saw less than 1/16th variance.

1 Like

Downloaded - Mac v1.12…

I was able to run the calibration test, so my fears of a dead motor are gone :slight_smile: Still getting eggs for .5" pocket cuts, but that is better than no cut at all!

Just had the same issue occur in the middle of a cut. Position is high to the left. Won’t even let me restart as it immediately goes into the sled position error every time I stop the GCode and restart at the offending line. My shield went bad and I just replaced it, so is this possibly the issue? Running GC v1.12, Firmware 1.12, Arduino 1.8.5

Please run with 1.13 GC and firmware

Reloaded everything including Arduino updates and the latest GC and firmware. So far it’s working better than ever! Might have helped that my shield was replaced as well.


After updating GC and firmware this problem went away for a while but unfortunatly it just happened again. The sled was in the upper right hand corner moving from right to left. Like last time even when I try to move the sled using the controls in GC, the error pops up. Any clues as to what might be going on? Thanks to all for the help and insight.


What is the max feed rate set at currently?

1 Like

Feedrate was set at the default 800. I lowered it to 500 to see if that would help and the error came up again.


Of course now I can’t seem to reproduce the error. I just ran the same file I was running when it first came up and no error. I ran it a second time at 1000 feedrate, nada. This is great but I know problems don’t typically fix themselves.


could it just have been a power supply issue? Maybe things got “too hot” and there wasn’t enough power supplying the motors?