Calibration step confuses z axis

When I tried to calibrate my z axis, it moves my left motor instead. Calibrating the left motor earlier in the process worked fine. The motor test sequence moves all motors correctly.

My left motor is plugged into the mp3 port, Z axis into the mp2 port
running ground control v1.1

2 Likes

I think that some others have seen similar behavior. I’m not sure I understand exactly what is happening, but I think it’s the software behaving in a confusing way, not a crossed wire or something similar. My hunch is to say ignore it for now.

Does it also move the z-axis? Or does only the left axis move?

What happens if you go to adjust just the z-axis when not during the calibration process?

2 Likes

Was this with weight on the motors, or were the chains off? When I don’t have my chains and sled resting on the motors, I get some strange behavior such as moving the Z axis moving the other motors too.

3 Likes

I’m having the same problem. Raising or lowering the z axis moves the left motor. I don’t have right motor nearby so I don’t know what would be the behavior with both motors connected. Changing motor cable from port 3 to port one has the same effect.

Motor has no load.

with no load on the motors, they will be extremely sensitive and move around.
Once they have the chains and the sled on them, it will settle down

David Lang

2 Likes

I am seeing this myself. It first happened when I upgraded to FW/GC 1.10 and then I attempted to revert back to 1.09 and it is continuing to happen. Load or no load on the motors. When I attempt to move the z-axis the z motor quickly twitches and then both the left and right motors make several rotations. I am currently unable to raise/lower the z-axis at all on my machine due to this issue.

I have an additional odd behavior in that during the calibration when the system wants to calibrate the chain lengths the motors turn the incorrect way HOWEVER when I enter into the stand alone automatic chain length routine, they turn the correct direction.

Perhaps related, when I am stepping through calibration it takes me through the beginning steps and then goes to the screen where it says something like, determining the proper calibration for your machine. It thinks for a minute but then takes me all the way back to the beginning of the calibration routine. I go back through using the skip buttons and then it does proceed to the next round of steps. Does that sound familiar to anyone?

Hmmm I fixed a bug yesterday which might be related to this. What OS are you using, can I send you a new version to try?

2 Likes

Absolutely, I am running Windows 10. I planned to go out tonight and spend as much time as I have to spend.

@madgrizzle has already walked me back from the edge of poor memory on the CW vs CCW motion of the sprocket during calibration.

3 Likes

When you get a chance give this pre-relase of 1.11 a try and let me know if it fixes the issue you were seeing.

https://drive.google.com/drive/folders/15YtPcQLdGKeBZml8Gjrna85cc2eNzQq9?usp=sharing

I would recommend renaming your groundcontrol.ini file to get a fresh start

1 Like

I will work on this at around 9PM eastern time and let you know how it goes.

I will also rename my .ini as you suggested. Should I wipe the eeprom as well?

1 Like

Great! I would say to wipe the eeprom too just be sure we’re starting fresh :wink:

After getting more time to work on it today, I have the exact same results as @arnoldcp, however my machine is running Ubuntu. Any help would be great.

1 Like

Alright, I have good news…did the wipe eeprom, then deleted the .ini file and then reflashed FW 1.10 and started up GC 1.11 pre-release. Walked through calibration and everything went as expected for the most part, I had one potentially non-issue which may simply be a purposeful choice.

The hiccup occurred when I got to the measure out chains screen, the left side retracted and the right side fed out, as it is supposed to. I did not hit the “Move to Center” button before hitting next and then going onto the z-axis setup page.

When I opened the adjust Z-Axis button and when I hit the Raise button the whole sled moved up about 100mm while the z-axis only twitched (which makes sense because the z distance was only set to 0.10mm). I initially thought this was doing the same thing as it was before and I clicked the raise button a couple more times. After a couple more clicks the sled seemed to incrementally work its way to the center of the work space and when it got there, the sled stopped moving and then just the z-axis moved when directed with button clicks.

I am not sure that I had clicked raise so many times in my prior calibration cycle so previously, the sled may have just needed to work its way to the center of the workspace while at the same time raising the z-axis. This may also be the preferred behavior? I am not sure.

The good news is that I got through the whole calibration and with just one iteration of test cuts I tried my circle test. I got my best results yet, only out of round about 1/16 inch! I think ill try another round of test cuts tomorrow and see if it improves even a little more and then start tweaking.

Hope that helps. Thanks for the pre-release!

3 Likes

You could get the pre-release here. Unzip it, change directory into the new folder and run GroundControl from that folder (not Linux savvy, but I think “python main.py” is the way). I see that @arnoldcp also deleted ‘groundcontrol.ini’ from the home directory and wiped the EEPROM using Actions/Advanced…

1 Like

After reading @arnoldcp 's results, I decided to try without updating the code, turns out it was just a centering action whenever I try to adjust the z axis inside the calibration. As long as its centered, then the left and right motors just sing whenever the Z axis adjusts, and out side of calibration it performs normally. When I open the panel to redefine 0 in the z axis, the motors still sing, but it does not attempt to return to center.

2 Likes

Excellent! Repeatable results! How many “bumps” did you have to give it before it worked it’s way to the center?

1 Like

I simply went back in calibration and moved it to center, so I did not get bumps, also, I was using the older software (I had limited time and know almost nothing about linux, I’m using it because my laptop doesn’t support graphics for ground control) But I definitely saw jitter in the left and right motors every time I adjusted Z. Does yours jitter when you adjust the z offset in the normal section of ground control?

It makes a high frequency buzzing, I assume verifying the positions of the left and right motors but they don’t visibly twitch.

2 Likes