Can’t get ground control to connect

I can get my surface pro gen 1 to recognize my arduino mega. The arduino sodtware to see it. But ground control REFUSES to connect! So ready to send this thing back! What is stopping ground control from connecting!? I only have one port. Everything sees it! Why is this CNC such garbage and WHY does Maslow not have tech support. Worst money I have ever spent PLEASE HELP!!

Do you feel confident the firmware uploaded successfully? Ground Control cannot connect to the Arduino if the firmware is not installed.

Which version of the machine are you using (ie where did you buy it)?

There are 3 businesses that sell maslow cncs, all of them have tech support via this forum and also email support. East Bay Source, Makermade, and Metal Maslow. Metal maslow has the firmware pre loaded, not sure if others do?

Selling the maslow kits is not that easy and I think most of the companies just do it as a side business. Having comprehesive tech support would make the kit cost more.

if you post a photo or screen shot of your uploaded arduino screen we can see if it loaded properly. Most of the people on this forum are volunteers, they are not company customer service reps. With an open source project the community helps make the product better.

1 Like

Your circuit’s dead, there’s something wrong.

It isn’t dead. I thought the same thing. There are SO many videos online on how to update it and only one that I could find on your site that explains you have to go into the update folder and open adruino in that folder. Worked like a charm.

I have done a major amount of research into this and have worked thru my problems. One thing I have noticed is that there is not a lot of info readily available on the web unless you look at several sources. So in light of all of this I have decided to make YouTube videos about this. I came into this thinking it was turnkey and I think a lot of other people think so as well. So I would like to help out those in my position. Hopefully this will help out and maybe answer some of the simple questions people may have. I know you guys are starting out and could probably use all the help you all can get lol. Thanks again for your response and maybe this will help everyone


Glad to hear you have worked it out! Nothing like pushing through to get it going. Thanks for doing the video. If we each document our trouble spots for the next person, it will fill in the gaps in the documentation. Please post a link when you have the video completed.

Space Oddity reference not acknowledged. I am disappoint. :cry:


Having the same issues getting mine set up. Can you explain about this update folder and how I should proceed?? Thank you, getting desperate!!! Thanks!!

look at the wiki instruction pages on how to set up and use the various software programs:

A couple links from the wiki I would check out for step by step instructions:

1 Like

Is it possible that the Arduino IDE is connecting using a different COM port than Ground Control?

another thing to look at is Ground Control is not really supported anymore. WebControl is really what is being used. I would look into moving to that as it has a little more user friendly options to upgrading the firmware.

Ground Control has been ported to the newest python version and compatible with the latest windows, Mac and Linux versions. It’s currently up to date and maintained by @EastBaySource

It’s compatible with any kit using mega boards. It’s very easy and straight forward to use. Will get the maslow well calibrated in no time with high accurate results.
In my opinion it’s still a valuable option.

1 Like

How do you hook web control to Arduino??

@2cents - I was wholly unaware that @EastBaySource was updating and maintaining Ground Control, so I will gladly recant my statement that it is no longer being supported! My apologies for the incorrect information!

@tliubakka For the installation of WebControl I have quoted the manual that was written by one of our Users (@Orob) to aid all users of the Maslow. Some of the parts may be dated, but again, this was a user created manual based off of what the community was generally asking questions of. With the knowledge that Ground Control is being maintained, either should work. I will say that in talking with @Orob, we are unsure if WebControl can update the firmware on an unprogrammed Arduino, but I think that is because it just hasn’t been tried/done before. Please let us know if you are still having issues, and if you can provide screenshots of what you are seeing, that could help us in determining what direction to go in trouble shooting. Are you showing a connection in Ground Control, but getting no movement on your motors, or are you showing that Ground Control is not connecting to the Arduino at all?

1 Like