Trouble with install, not sure if it's Arduino or Maslow problem

I am having trouble with the install. Followed instruction and then when opening Ground Control and trying to make a connection it stays in a loop of Connecting and then error message of Timed out.
I have reload both programs several time and continue to receive the same message. Lost as what to do next. Help!
My HP always wants to load Com 4, not sure if it’s correct or not. My understanding is that that it is automatic with the software install and my computer.

Let’s figure out what’s going on!

The connected disconnected loop can happen when either the port is wrong or when the firmware hasn’t been uploaded to the Arduino successfully. Did the firmware upload process go smoothly? Was COM4 the port you used during that process?

And make sure you close the arduino programmer application. It can interfere with GC as well.


Yes the upload went very easily. The only item of confusion was where to download the software. Used Arduino Web App and let it load where it wanted to. Then the Maslow Frimware load into a temp file of it’s own making and finally Ground Control which loaded by itself under the Arduino file folder. Don’t know if this is correct but that’s what it did.

As for COM4 it’s the location that the Maslow CNC controller and Keystudio Mega 2560 said it was connected to.

Hmm I haven’t used the Arduino Web App before, I think it might be necessary to download the Arduino IDE and install it to get the proper drivers to make everything work. I could be wrong, but the first thing I would do is to download the Arduino IDE and try to upload the firmware that way.

1 Like

Bar, you say download Arduino IDE. I thought that it was the one and only program. One that had three different ways of downloading to Windows.

Windows Installer for XP and Up, Windows ZIP for non Admin install and Windows APP for win 8.1 or 10. I used Windows APP as I’m run Windows 10.

Should I uninstall the Arduino now and then re-install using Windows Installer for XP and up?

What about the COM 4 setting, does this sound correct?

Sorry, my confusion. I thought you were saying the Web Editor, you are right that the app version should work. I use it myself. I was thinking we were talking about these two:

Ok, so then let’s confirm that we’re looking at the right port and that the firmware is sending information back to Ground Control.

To do that close Ground Control and open the Arduino IDE and click the magnifying glass symbol in the upper right hand corner:

Change the connection speed to 57600, and you should start to see the machine reporting it’s position like this:

Is that what you see?

1 Like

Surprise, this is what I see!

I’ll be you were not expecting this look.


Excellent! So we know the issue is with uploading the firmware. What do you see after pressing the upload arrow button? Does it look like this?

1 Like

No I get an error message.
Arduino: 1.8.5 (Windows Store (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

C:\Users\Jeff\AppData\Local\Temp\\Firmware-1.17\cnc_ctrl_v1\cnc_ctrl_v1.ino:36:20: fatal error: Maslow.h: No such file or directory

#include “Maslow.h”


compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.


The firmware is not unziped/extracted
Once you extract it and upload the firmware from that unpacked folder, it should work


I just realized that and un-zipped.
I have tried to to post but the window will not allow it.

Message say that my Maximum is 8192 bytes. Should I change it?

1 Like

I’m not sure I understand, where do you see that message?

Looks as if it now works, however received this message when I opened Ground Control and connected.

Connected on port COM4
PCB v1.2 Detected
error: EEPROM read fail. Using default settings.
CRBL v1.00
Ground Control 1.17
Frimware Version 1.17

G00 X-100 0 Y-100.0


Excellent!! I think you are all set! That warning about the EEPROM read fail means that the machine was unable to load your settings from last time, but you can ignore it because this is the first time you are powering it up so it has no settings to remember. You won’t see that warning again.

Great work!!

Thank you so much for the rapid reply’s and having to wait on me to respond.
Great work on your part. Now to finish the building part.


Absolutely! My main goal for the next few weeks is to make sure everyone gets set up so I’ll be extra available if you need anything! :+1: :+1:

1 Like

PowerBall Lotto winning numbers would be great! Just send them my way.


Hi, I’m not sure if this forum is still working but if you receive this message perhaps you could respond please. When opening Ground Control I get a message loop “Connected on Com Port 2. Connection timed out”. I’ve checked the com ports match in both GC and Arduino, and they do, I’ve also checked the firmware has downloaded ok and it has. I’ve uninstalled and reinstalled the software twice but continue to get the same error message. Any suggestions?

Comm Port 2 is normally a computer serial port. But with that said, make sure the Arduino IDE is closed when you try to run GC as it can interfere with it.