Cannot connect with my phone

It seems like I have my machine almost set up (other than some issues with the Z-access calibration)! Yesterday I was able to connect with my iPhone. Localhost did not work but when I entered the IP address displayed in the Webcontrol screen on my windows 7 laptop followed by :5000/# it worked and I was able to access Webcontrol and control the machine. Todays nothing. I noticed the IP address displayed in Webcontrol had changed so I tried the new address and that did not work. What am I doing wrong. Can I set a static address on my laptop and would that help?

the device you are running webcontrol on is geting it’s IP address from your
wireless network, you would need to set a static IP address for it (i.e.
reserved address) in the router configuration, or find the IP range that it’s
giving out as dynamic addresses and pick and address outside of that range to
give as a static address for the webcontrol system.

David Lang

Thanks David. Are there any security concerns around assigning a static ip to my laptop? I am also getting an error notification when returning my sled to home. I have attached a screen shot.

no, dynamic addresses can be found pretty easily so there is no security reason
to not use static addresses. It’s just a matter of convienience, when nothing is
trying to talk to the device, it doesn’t matter what address it has.

I’m assuming you are running webcontrol on the laptop, not a pi? if you are
running webcontrol on a pi, that’s the device that needs the static address.

David Lang