Can't calibrate Metal Maslow, motors don't work correctly

I’ve finally finished building my Metal Maslow and I’m running into an issue trying to calibrate, my motors don’t seem to be acting right at all.

Whenever I try to use the shuttle controls, or try to use the Z-Axis up/down buttons in the calibration steps, it moves the sled down about 1/4" and then shows an “ALARM:3 (Abort during cycle)” in the console. It moves both the left and right motors, even when I’m trying to only move the Z motor, and the Z motor never moves. There’s also a whining sound for a second or two after they stop moving, I’m not sure if that’s normal.

Here’s a video of what happens when I push the Z-Axis Up button (10mm) in the calibration window:

Some details:
Kit: Metal Maslow
Board: Arduino Mega
Firmware: MaslowClassic v51.28
Computer: Raspberry Pi 4
Software: Makerverse (1.1.3)

If anybody has any ideas of what steps to try I would greatly appreciate it.

I’m not too familiar with Makerverse. However you can try webcontrol and see if you get the same issues. Reseating all cable connectors can help. See the Maslow Manual link below it has info on the entire setup and Makerverse. Added another link for the basic and advanced features of webcontrol.

Ok, I tried installing webcontrol on a different computer and got the same result. When I hit any of the up/down/left/right controls it only ever goes down, and only by a tiny amount (about 0.25") regardless of the distance entered. And the z-axis control does the same thing: the z-axis motor never moves but the other motors both do, even though they shouldn’t for that function.

Interestingly, webcontrol has a “test motors/encoders” button and that seems to work correctly. Each motor runs independently forward then back a small amount. Including the z-axis motor, which I’ve otherwise never seen move. And I don’t hear the additional whining sound after they stop moving.

I tried unplugging and re-seating all 3 motor cables. I also ran the firmware update function in webcontrol (I tried all 3 available firmware types) to ensure I don’t have bad firmware loaded. Nothing has made a difference so far.

Follow the help menu in webcontrol or the tutorial that I posted. I had the same problem when I ran out of bounds, the only way I could figure to solve it was to redo calibration from the very beginning.

Ok, I’ll take another look at those. Thanks!

Thanks @TimS, I was able to get up and running in Webcontrol with those tutorials and make my first cut! I’ll probably try to get Makerverse working soon to compare, but I’m glad to at least have things operational.

1 Like

There are more videos available on how to use makerverse as well… just further down in the manual.