Maslow Home Maslow Community Garden Newsletter

Calibration Woes

Hi all. I’ve been lurking here for a while, gathering info and reading as much as I could while I got my setup put together. I have been taking it slow (mainly due to holiday shenanigans and watching after the kiddos). I got all set up finally this evening, and have been working on calibration. I’m having odd motor movement behavior though.

My setup is:
MetalMaslow kit
1.5” square tube frame
12’ motor spacing on a 13’ top bar
Full 49”x97” 3/4 MDF wasteboard
Chains over top with a simple counterweight setup
Makerverse 1.1.2 on a pi 3b+ with a 7” touch LCD
Firmware updated to 51.28

So I connect to my new machine, leave the default workspace settings, hit connect. It prompts to start calibration. Stepping through the tabs:
First few go fine

Z-Axis: left and right motors hum, z never moves. I understand this could be due to never having defined a home through the set chains process.

Skip to the chains tab. I had already adjusted my chains to have the sled hanging as close to home as I could (center of wasteboard). I take it off, connect chains together, and get started. Make a big step in the positive Y by 500mm. Goes fine. 100mm. Goes fine. Decide to do smaller steps rest of the way up. 50mm. Goes fine twice. Then the next attempt at 50mm and the motors hum but don’t turn. Wiggle all the cable ends, try again. Goes. Next time fails. Wiggle cables. Fails. Down 50mm. Fails. Up 50mm. Fails. None of these failures are tripping alarms in the terminal window. I decided to try the X movements. Move X left and then right. No issues. Try Y again, still just motor hum. I’m so confused. At this point, every X move is successful and every Y move fails up or down. At first I thought it was a connection issue, but that wouldn’t explain all the successful X moves.

I’m sure it’s something simple, but what am I missing here?

Here’s my setup in picture form. The extra frame around the wasteboard is for an additional skirt when I get set up and want to cut to the edges of a full sheet of plywood. Just haven’t ripped down the MDF for those yet. I also plan to paint the frame, but it’s too cold and my shop isn’t heated, so that will be a springtime project.

1 Like

I am kind of baffled. If I was faced with this I would go back to the very beginning and redo every step in order very carefully. I am guessing for some reason the system does not know what to do with certain commands. I’m not familiar with the Makerverse software, I have only used ground control and webcontrol.

1 Like

what alarms are being tripped in the terminal window? is it the ‘sled can’t keep
up’ error?

if so, slow your feed rate or increase the threshold for the alarm.

David Lang

That’s the thing though, I’m not seeing any alarms tripped. And it made successful Y moves before it stopped. I did see a couple alarms when I was tinkering with trying the Z axis, but none for the X-Y movements.

Yeah, I think starting over on the calibration is a good idea. It looked like makerverse was the software getting the most love right now. But, it seems like web control might be an easier to use platform. If I keep getting stumped, I may try swapping.

1 Like

a few have had luck with weird problems by resetting the board memory $rst=* and then recalibrating. I don’t know if that is the answer for you, but it might be useful to add to your list of approaches.

Thanks! Is this the same command that is sent when you tell it “yes, it’s a new machine” in makerverse setup? Wasn’t sure if I deleted the workspace and started over fresh if it would automatically issue that command?

Also, I have a second SD card with nothing on it. I am thinking of stepping through the web control install with it to test my results. Will both webcontol and makerverse use the same firmware on the mega? Or do I need to reflash it also?

51.28 will work for holey calibration with webcontrol. You will need to flash it if you want to do basic triangular cal

Well I have progress! @Orob I found your video on Makerverse calibration and watched you step through it. Looks like one thing I was missing was resetting the chains. I did the $RST=* command, reset chains, and then started fresh on the calibration. I was able to make it all the way through edge calibration without issue! :smile:

3 Likes

That is GREAT NEWS!! good job!

1 Like

Now to figure out the correct makerverse settings for the MetalMaslow Z axis. It is not behaving as expected…

yeah about that… I have one but have not set it up with the mega. I got it working with the due. There are settings in another post that worked for webcontrol that should be similar. The issue with the faster z motor is that you need to adjust the PID settings to get quick movement without overshoot.

try here:

I actually found this: C-Beam Axis with Metal Maslow Sled - #42 by Metalmaslow but I’m a bit confused on what to put on the z-axis tab during calibration as it doesn’t look like there is a spot for any of those numbers :exploding_head:

you can roll it back to the main screen and input the information there as long as you don’t wipe the settings the next time into calibration. You don’t have to put anything there if it works.

So I have successfully done edge calibration 2 times. Its not great, (currently at 19.6mm error). I want to give the precision calibration a shot, but can’t get the Z-Axis to do anything. Currently, if I tell it to move either direction, the left/right motors hum and Z stays put. I have tried adjusting the pitch and resolution settings on the Z-Axis tab, but no changes seem to help. I guess I will exit calibration for now and see what happens when I try adjusting the Z-values per the link above.

Another user just updated to 51.29 here and said it worked, but they had verified ground control worked before makerverse…

I got cold and left the shop last night :sweat_smile:. I never got accuracy below 19mm with edge calibration. Does that sound normal? It sounds way off to me.

I have a webcontrol image loaded on my spare sd, so I contemplated trying it tonight. But, since it uses holey calibration if I can’t figure out the Z axis then I’ll be stuck with it too, so it may not be worth the effort.

I didn’t know 51.29 was out. What benefits does it have over 51.28? Also, can you point me to their thread?