Maslow Home Maslow Community Garden Newsletter

Gone from great to terrible

The Maslow was working great until I made two changes. First I downloaded this webcontrol-0.927-win64-singlefile, thinking it was a needed update. Unfortunately I didn’t run the system before I switched to the Metalmaslow sled with the arms. Now I’m getting calibration problems and erratic operation. Doesn’t matter if I use groundcontrol or webcontrol. After calibrating with webcontrol I tried to cut the test pattern. It started to cut a much smaller pattern than expected. Tried to set the z axis, Instead of moving the router in and out the sled moved down. Tried calibrating in Groundcontrol. Steps going along fine until I got to the point of extending the chains. The right motor extended to 1651mm approx. The left motor only extended about 1/3rd of that. Should I try to reset everything and start over?

1 Like

I think that sounds like a smart place to start. I bet something went wrong with the settings file in the update.

Additionally, you need to change the z-axis pitch and change the sign of the number since the motor is rotated 180 degrees. I am nowhere near my Maslow, so cannot verify the number I am using for the z axis pitch.

Just now reset EEEprom and default settings. Using ground control. Tested motors and encoders. Had a pass and a fail on the left motor the first time. Tested again and had a pass and a fail or the right. Also a pass and a fail on the Z. Finally all all passed. Got to the point of extending the left chain but only 1150mm extended. Left extends 1651. Seems like I’m in for the same problems so I quit calibration. I appreciate the help.

Thanks, I set it for -8.

I ended up deleting everything and started over from scratch. Back to working again! Thanks

2 Likes

I think this was probably the issue and it didn’t have anything to do with the upgrade of webcontrol (webcontrol upgrades don’t change settings). I assume when you made the switch, you didn’t change any settings and went straight to calibration. If this assumption is correct, the problem is that the rotation radius of metal maslow is significantly different than that of a ring kit (which I assume you were previously using). As such, the cut pattern will come out very distorted because the rotation radius is so far off. Even if you successfully cut the pattern and enter measurements, you’d have to repeat the calibration procedure at least one more time to get the system in the ball park and maybe another to fine tune it. What you should have done (and don’t take this as a derogatory comment) is updated the rotation radius either in settings or by using Actions->Quick Configure. That would have gotten the rotation radius close to what it should be and the calibration cut would likely have come out much better. Still wouldn’t have hurt to do a second calibration to fine tune it.

I think there’s some firmware bug lurking around as this has happened before to people in both ground control and webcontrol. I don’t see any reason for this to happen (I assume you used the Z-Axis popup button to adjust it?)

So many people have run into this using ground control that I didn’t include in WebControl the part of ground control’s calibration where you measure the distance between motors.

1 Like

Thanks for the help! I think some of this was user error. At some point I noticed I wasn’t allowing enough time for calculations to complete. The Z issue was because the motor is now inverted. I had to change the pitch from 8 to minus 8. I’ll check on the rotation radius!!

1 Like

I really suspect the chain extend issue was related to this… it happens to sooooo many people (happened to me when I first started).

From what I saw on another post, the rotation radius of metal maslow is 180.34mm, for comparison, the ring kit is 138.4 mm. That’s a big difference and would explain your issues. I’ll probably go ahead and add the metal maslow setup to the Quick Configure. @Metalmaslow, is 180.34 mm the proper rotation radius to include as a default setting?

1 Like

Thanks again!

1 Like

Set the rotational radius to 180.34, made a big difference. Also discovered I was screwing up the calibration. After I entered the measurements I hit calibrate but never noticed the “accept” button below. “Home” still doesn’t match the center of my 4x8 but I think I can deal with that.

1 Like

Not the first person that happened to. I’m thinking of changing it so they are on the same row (left to calibrate, right to accept).

There’s no real guarantee center (0,0) is going to come out in actual center. How far off is it?

It’s 20mm right and 12mm low. The red crosshair shows center of the display.

The up/down could be “residual” error from the calibration. Calibrations aren’t perfect (i.e., measurements aren’t perfect and the model isn’t perfect). The optimization routine may have had to reduce the height of motors above worksurface to get the calibrated model to match the measurements.

A left/right offset of 0,0 can occur if the board is not perfectly centered between the two motors but can also be caused by residual error… the calibration might have adjusted chain tolerance during the optimization process and this could lead to left/right differences (or it could be a combination of board centering and chain tolerances).

Bottom line is not to worry unless you see problems with the cuts.

I can work with it!

being 20mm off sounds like it will be a problem, the chains should be within a
mm or so of each other.

David Lang

I’m going to run a test piece and see how it does. If corrections are needed does it make sense to put a tooth at 12:oclock on both motors and lift the chains to the spots I marked and run the triangular calibration again? The last three calibration attempts put the cuts in the same spot.

The only time you need to reset the chains is if the controller loses position or the chain has skipped a link.

I’d say run some test cuts and if they come out as you desire, don’t worry about it. I think there’s a benchmark gcode around somewhere that does squares and such around the edge of the board to test how well its calibrated. I don’t have it handy though.

If you have the calibration good, you just need to reset the chains to the
marked points (on 12 o’clock sprockets)

the regular triangular calibration has significant limitations, I would suggest
that you try using webcontrol and the holey calibration and see if it works
better for you.

David Lang

Thanks Dave, I am using webcontrol. Holey calibration isn’t available in the actions menu, the selection is inactive. Do I need to download something.