Maslow Home Maslow Community Garden Newsletter

Can't load gcode (Final sled gcode)

can’t seem to find it anywhere???
any help would be appreciated.

It should be in a folder called Gcode when clicking the “download” button under the “files” tab here:
http://maslowcommunitygarden.org/Maslow-Ring-System.html?instructions=true

strange i keep getting an error “can’t reopen gcode…” tried moving it to different folder and restarting GC

image
is it possibly corrupt?

just tried a different gcode file i downloaded from the community garden (letter box) and same message :frowning:
BTW i’m on Win10, ran the calibration and triangle test cuts fine.

Hmmmm
if i go into the gcodeForTesting folder in maslow portable i can load those files!

‘cannot keep up’ message will not be fixed by using different gcode (unless the
different gcode has different feedrate settings in it)

you need to figure out why the system isn’t moving fast enough.

can you put a meter on your power supply to see if it drops from 12v when you
are trying to cut?

David Lang

sorry, responding via e-mail I thought you were getting a different error

how were you trying to load the file before you went into the ‘for testing’ directory?

Do the files you’re unable to use have spaces in their name? I think I remember that being an issue…,

same way. actions-open file
any file in the testing directory works.

no, its called sled.nc

Can you attach the file to a post in this thread? There might be something in it…

Will that file load if you copy it into the testing directory?

no I tried putting it in that directory. I loaded it from github the link Bar provided.
Sled.nc (1.4 MB)

The file you have in your post is not a CNC file or G Code should look like below when opened in notepad. Looks like you downloaded the web page and not the NC or G code.

(Cut Alignment Holes)
G0 Z0.15
T0 M6
G17
M3
G0 X9.4278 Y15.5706
G1 Z-0.12 F30
G3 X9.4178 Y15.6207 I-0.1309 J0 F20
G3 X9.3895 Y15.6631 I-0.1209 J-0.0501

1 Like

You’ve put your finger right on it! That looks like the source code of the Community Garden web page for the sled.
Here’s the file:
Sled.nc (149.5 KB)

1 Like

what directory is failing?

well thats embarrasing! thanks so much for your help.

next time i guess i should just download the zip file instead of trying to get the gcode by itself

1 Like

That’s the easiest path. Github is a world unto itself, and many things are possible, but I ask myself - “do I want to learn github, or make wood chips with my Maslow?” :grin:

:+1: thanks again!

1 Like

Ok, I know this is a pretty old thread but I’m new and having trouble. I bought a Maslow during the second offering and it’s been in a box ever since. Space constraints. But, I finally put it all together and I’m having all sorts of problems. With this thread, I can’t find the sled.nc file in the 1.26 version of GroundControl. I downloaded the code for the center hole knockout from above because I thought that would be easier to mount in the final sled anyway. Question: Is the image of the item you’re cutting supposed to appear in the rectangle main screen view with the cross hairs? I’ve loaded several “.nc” files and I can’t see what I’m cutting. I’m also having issues with dialing in the calibration, but I thought I had it worked out. I’ll post in a different thread if that fails again.

Hmmm what do you see in Ground Control? Can you post a screenshot? It might help us to figure out what is going on.

The image of what you are cutting should appear on the rectangle in Ground Control, but where it appears is based on the gcode so it is possible for parts to appear outside the rectangle.