Maslow Home Maslow Community Garden Newsletter

Ground Control not "seeing" gcode files

#1

Hi all! So we are ready to cut our final sled and I am not able to see any .nc files when I go to “Open File” in Ground Control. It shows an empty directory.

I checked and I see the .nc file is there but GC can’t seem to locate anything it thinks it can open (no file in display)

I tried a cursory search of the forum but can’t seem to locate this issue anywhere else. Am I missing something?

0 Likes

#2

Not to insinuate anything, but are you sure you are looking in the right folder? (assuming windows here)
You can navigate to other folders from the Open File window, and the folder address should be visible at the top

1 Like

#3

Keith, thanks for the note and yes, I am sure I am looking / navigating to the correct location.

I AM able to see the gcode test files in the ground control folder - Interesting note - when I relocate my sled.nc to that folder it still shows up in the ‘files’ view but when left on the desktop it doesn’t.

2 Likes

#4

Also check that your folder paths have no special characters. MaslowCNC is intended cross-platform and therefore not too tolerant. a --> C:/user/jack%#the#%ripper/Maslow can have negative impact.

0 Likes

#5

Which view are you talking about?

Have you tried putting your file into the same folder as the test files? (I think that is what you are saying you did… see below)

I am having just a little trouble understanding where you are looking when. From what I understand, you know how to navigate to the desktop while in the “Open File” window of GC, and when you navigate there, your file is not listed in the “Open File” window. Is this correct?

I am keying off the above statement.

What I am confused about is if you can see the sled.nc in the GC “Open File” window when you put it in the same folder as the test files, what is the problem? I mean aside from it not showing up when on the desktop.

1 Like

#6

Not sure if this applies here, but my guess is that a link to a file will not be followed by GC.
If “don’t show file ending for known” is turned on, you might not notice.

0 Likes

#7

I guess what I should have asked is if there is a special paths issue for where I can put my gcode files that GC will read. It appears the only place the files are read are when they are placed in the testgcode folder under GC

1 Like

#8

That sounds more like a permission issue. Win$ is not really my field, so will back off.

0 Likes

#9

I have had no problem putting my files into a folder on the desktop and navigating to that folder, and sub-folders within it. That said, I am using a much older version of GC, but I can’t imagine that that kind of functionality would have changed.

To be certain I am clear, though, you are able to get to your file?

0 Likes

#10

this is most likely to be permissions or a special character somewhere in the file path.

0 Likes

#11

I can’t save or find anything on my new computer.
Edit: I assume I can save them.

0 Likes

#12

I regularly create my NC files on my main Linux box, put them into Dropbox and have absolutely no problems accessing them on the Win 10 laptop the Maslow is connected to.

0 Likes

#13

if your user name contains non basic characters, then you should put them in the \users\public\ directory, and see if you can access them from there

0 Likes

#14

I am stuck too. Files in dropbox wont view in GC. Files on Maker Made USB wont view. Files in Public folder wont view. See photo of file path, no special characters. I am stuck now not being able to cut the sled. Help please.

0 Likes

#15

How did you receive them? Are they zipped? What ending do they have? Can you post 1 of the files?

0 Likes

#16

for the short term, try putting the needed file into the same folder as the gcode test files in GC as SnapShelter did. That way at least you should be able to cut the sled and get going.

Does anyone have a take on this issue being related to a change in permissions in newer versions of GC?

Good questions!

0 Likes

#17

Not zipped. Downloaded from the assembly guide but not .nc files. Put them into the GC test files folder. Can see the .nc test files already there.
See screenshot.

0 Likes

#18

Ground Control doesn’t understand how to parse SVG and DXF files. You need to open these with some sort of CAM tool (MakerCam, for instance) and have them processed into .nc files.

2 Likes

#19

Yep, I am getting there slowly! I had wrongly assumed that the files I downloaded from the sled instructions would already be configured for GC already.

1 Like

#20

Unfortunately, since people will use different sizes of end mill, and possibly different materials, posting a CAM file is not generally a great way to go.

Fortunately, with the files you have (SVG) you can quickly get your CAM file created using something like MakerCAM or JSCut online if you don’t already have a CAM program.

2 Likes