Chain comes off during tightening phase of calibration

I feel like I must be doing this wrong. I’ve tried twice now to run through calibration and I’m not having much success. I get the chain extended out (which feels like it takes forever) and attached to the right sprocket per the instructions, making sure to get the third link over the sprocket. As soon as I press the pull chain tight button, before I can even look at the chain and move the mouse to click the measure button the chain goes tight and flies off the sprocket.

Any suggestions? I got two different (presumably bad) measurements, 2993.7 and 2975.4. Measuring by hand, I would’ve put it closer to 3010-3015. Not looking forward to doing this again with the same outcome. Seems like the calibration would go a lot faster if we could just start out with both ends of the chain on the sprockets, and just tighten from there, which would be like 50cm travel. I guess that depends more on the exact chain length being known/trusted.

1 Like

This thread has a number of suggestions from others who had the same issue:

1 Like

could you make a video of it so we can see what’s happening? you aren’t the
first person to report this, but it’s not common.

I can try to take a video. After reading the thread bar linked, I’m wondering if the 12 o’clock alignment is the issue. The pictures really look like it is past 12, and I’m guessing even just a little more angle might make a difference.

Ok, off to figure out a camera setup and try again.

Also make sure you are giving the slack portion some downward pull, that solved it for us. We were just letting the chain sit there alone and it didn’t like it… pulling down on the long portion of the chain while it tightened allowed it to tighten properly without jumping off.

1 Like

The slack portion on the left side? My chain is coming off of the right sprocket, but I guess I could try pulling on the left side. A major issue for me with all of this is that I don’t have anyone to assist me at the moment, so I’m running back and forth between the laptop and each end of the machine.

I’ve got a video of the right side during calibration, I’ll post it as soon as I can cut it down to the few seconds that matter.

Out of curiosity I went on to the next step of calibration this time anyway, just to see if I could make any progress. I think there’s something wrong with my machine. The left side only fed about 32" of chain, compared to the right side feeding about 58" of chain.

Also noticeable to me is the sound of the left motor has never seemed right. I’m used to hearing my 3D printer stepper motors, and the right one sounds more like that. The left one makes a louder lower sound, sounds like it is straining to move even when just feeding 10mm of chain, or when adjusting the sprocket for 12 o’clock position. It seems like I have to make the 5 degree movements on it for any noticeable movement to happen. The right side seems to respond normally to even the 1 degree change. I’ll post a short video of each to compare.

It’s almost like deja vu, there is definitely a gremlin somewhere causing these same issues because many of us have noted the chain length differences and also the motor sound differences!

Try restarting the whole computer and killing power to the Arudino every once in a while, that seems to have corrected some weird behavior in ours.

I didn’t realize you meant it was flying off the right motor, maybe a light clamp over the chain/gear? I bet the “shock” of the chain tightening is popping it and once that initial jolt is over it would stay on.

1 Like

Interesting, you can see the sprocket rotating CCW under tension… I wonder whether the set screw is seated on the flat of the motor shaft?

1 Like

Also, the motor mount lifted up a little as well. I’ve never watched a tighten-chain sequence before so don’t know if it’s normal to have such flexing. Thanks @demotivator for doing this.

1 Like

I confirmed the set screw was seated on the flat part of the shaft.

I made another attempt this morning. I decided against using the chain tighten button, and just set the retraction increment really small and kept telling it to retract until I felt like the chain was tight. This resulted in a higher measurement than before (3023 I think), and the chain did not come off.

I moved on to the test cuts. First and second cuts were fine. Third cut I forgot to turn the router back on before hitting the button to continue, so didn’t start cutting in the right spot. I let it keep going, hoping it wouldn’t be a big issue. While recording a video of the process with my phone I failed to notice the chain start to wrap around the right sprocket, so I had to run to the laptop and stop the cut. Hopefully didn’t damage anything.

I’ve got the chain unwound, will work on this more after lunch. I think I’ll take the time to install the Z-axis kit on the temporary sled to make my life easier during calibration. I didn’t think it’d be worth the hassle, but I clearly need to let the machine automate as much as it can :slight_smile:

For fun, here’s a picture of my failed test pattern cut.

1 Like

Is it normal for the calibration process to feed so little chain out during the step when we’re supposed to attach the sled? I think I measured maybe 64" of chain. Since I’m working on this alone, it resulted in me having to do the following in order to get the sled in a workable position to attach both chains:

And then, once attached:

It would be a heck of a lot easier if it just extended enough chain so the sled could rest on the ground while you attach it.

After watching the video of that mishap, I discovered the reason for the chain wrapping around the sprocket was that the chain tensioning was not doing its job. The chain started to sag down to vertical below the sprocket and pretty quickly got caught between the sprocket and the chain running to the sled.

I already wasn’t happy with how the bungee tension was working, so I think I’m going to go make some modifications to switch over to counterweights before I try calibrating again.

1 Like

Excellent isolating of issues and solving them!

There should be a “move to center” button in that step which will extend the chains to a length which puts the sled roughly in the center of the sheet to make it easier to attach

1 Like

After attaching the sled I pressed the move to center button and I’m not sure it moved even an inch. The buttons change from “adjust” to “extend”, but once it has extended that first amount of chain the buttons don’t appear to do anything. If they could actually extend more chain, maybe 100mm increments or something and just track that number, I could manually extend the chain until it was the length I needed.

For me, holding a 25lb sled several feet off the ground while simultaneously guiding a floppy chain through a small hole and precisely sliding the cotter pin through the first link is not something I can do with two hands. And then I have to grab a second chain that is about 5 feet away from me while holding the sled in the center of the frame so I can repeat the process. Much easier if the sled is resting on the ground.

I guess I should go clone the ground control git repo, I could probably code what would solve my problem and submit a pull request.