Maslow Home Maslow Community Garden Newsletter

Defining new Center Point (Not Home)

groundcontrol
accuracy
calibration

#1

Just what it says. The calibration process is 99% finished. The Center Point is about 8 inches low and about an inch to the left of the actual work area center. Rather than go through the calibration process again (it’s about my 6th time now), I’d like to manually move the router to the measured center of the work area and call that the new center (0,0,0). Is there a button that will do this? I can set that as the home point but when I run the chain sag calibration it returns to the low “center” point. I’d like to do this so I can finish the chain sag portion of the config and get cutting. Side note: I tried a test cut without finishing the chain sag and my circle came out as an oval.

Any help would be appreciated. Thank you!


#2

It was requestet several time, to let the user tell the software where X0/Y0 is. But only to take the calibration from there to achieve better results.
GC also takes the dimensions of the sheet to determine how far it can go, so setting 0/0 somewhere else would result in not going far enough on one side and too far on the other.
For being too low, the first 3 things I would check is the motor distance, rotation radius and height of the motors over the sheet.
For being off to the left only a not level top beam or different chain stretch would come to my mind. (sure you sheet is in the middle)


#3

Would you like to
a) share your frame description if anything special compared to the default frame size.
b) then attach to your reply your groundcontrol.ini file?

(note: I will not be available to check it until thursday, but I am sure there is something special here. and maybe someone will point it out before me when looking at your response)


#4

Hey and thanks for your reply. I just checked the motor distance and it is correct as far as I can tell. The height of the motors over the sheet (Distance from the center of the sprocket to the top of the working area) looks to be correct. It may be a little longer than it needs to be because I did take the distance as a crow flies and not just in 2 dimensions. Rotation radius is the default 140mm for my ring kit. I’ll take another look just to be sure.


#5

The frame is the default size for the working area. I did change the back of it so it will fold up and sit flat on my wall but the cross beam is still 10’ and all the other dimensions fit the original frame specs. Now that I’m looking at it, It says my bedheight is 1.2m. Is that the reason it’s off? Sounds like I just need to redo the whole calibration.

Here’s the .ini data:

[Computed Settings]
distperrot = 63.5
kpposmain = 1300
kiposmain = 0
kdposmain = 34
propweightmain = 1
kpposz = 1300
kiposz = 0
kdposz = 34
propweightz = 1
kpvmain = 5
kivmain = 0
kdvmain = 0.28
kpvz = 5
kivz = 0
kdvz = 0.28
chainoversprocketcomputed = 1
fpwmcomputed = 3
kinematicstypecomputed = 2
distperrotrightchaintolerance = 63.50000
distperrotleftchaintolerance = 63.50000

[Maslow Settings]
bedheight = 1219.2
openfile = /Users/Kasey/Desktop/Nc Files/Test.v1
motoroffsety = 482.6
sledwidth = 140.0
zaxissafeheight = 5
bufferon = 0
bedwidth = 2438.4
comport = /dev/tty.usbmodem1411
macro1_title = Macro 1
sledheight = 139
macro2 =
macro1 =
zaxis = 1
sledcg = 79
macro2_title = Macro 2
colorscheme = Light
zdistperrot = 3.17
motorspacingx = 3008.91

[Advanced Settings]
rotationradius = 140.0
chainextendlength = 1650
kiv = 0
gearteeth = 10
spindleautomate = None
kdvz = 0.28
chainsagcorrection = 0
chainpitch = 6.35
chainlength = 3360
propweightz = 1
zencodersteps = 17280
maxfeedrate = 800
enablepospidvalues = 0
rightchaintolerance = 0
enablevpidvalues = 0
maxtouchprobeplungedistance = 0.0
kpvz = 5
kdposz = 34
chainoversprocket = Top
kpposz = 1300
fpwm = 490Hz
kdpos = 34
encodersteps = 8113.73
truncate = 0
homex = -30.0
homey = 273.29
kinematicstype = Triangular
kipos = 0
kdv = 0.28
kiposz = 0
digits = 4
kppos = 1300
kpv = 5
propweight = 1
positionerrorlimit = 2.0
kivz = 0
leftchaintolerance = 0


#6

chainoversprocket = Top
chainoversprocketcomputed = 1
means your chain passes over the sprocket before going to the sled.

distperrotrightchaintolerance = 63.50000
distperrotleftchaintolerance = 63.50000
means you have not tuned the chain tolerances yet.

motoroffsety = 482.6
is the 2D vertical distance of the workspace top edge to the sprockets.

comport = /dev/tty.usbmodem1411
this is not a windows machine,

zaxis = 1
your Z axis is motorised

motorspacingx = 3008.91
means the distance between sprockets center is that

rotationradius = 140.0
if you use the rotation ring kit, the exact value is 138.14 mm

chainsagcorrection = 0
There is no sag correction for your lower corners. It will likely be too narrow at the bottom.

chainlength = 3360
You got 12 feet chains right?

zencodersteps = 17280
This is not the standard Z motor encoder setup.

Here are your choices for the home position:
(set when clicking on “define home” among the GroundControl upper right screen buttons)
homex = -30.0
homey = 273.29

kinematicstype = Triangular
the ring kit is what you use…

leftchaintolerance = 0
rightchaintolerance = 0
means you did not yet adjust chain pitch to improve precision ( this will eventually be assisted with the Holey Calibration)


1.2m = 4feet. that is the height of the workspace. then the top edge of the workspace is sais to be at 482.6mm.
Is that not right?

Have you chosen to place the home position at (-30,273.29) so it would look centered?


Sled will not go to top of board same parts are cut different sizes
#7

I think that’s the issue. The height of the motors over the sheet should just be the vertical distance to the motors. I think when you fix that the issue will be solved in the vertical direction. As for left and right, are you sure that the sheet of plywood is mounted exactly between the two motors? You can always jog left and then click “define home” but if you want the machine to think that a different point than directly between the motors is zero you will end up with funky calibration