Maslow Home Maslow Community Garden Newsletter

Easel GCode Import off Work Surface

I set up a project in Easel to cut the final sled, exported the Gcode and imported into GroundControl. When I imported, the tool paths are indicated as being about 20-30 feet below my work surface and I cannot figure out how to move it onto the work area.

Is there a trick to this or is there something I’m doing wrong in Easel?

Thanks!

You have likely drawn the part in easel far away from X0/Y0.
You could try ‘clicking and holding the mouse button a few seconds’ the same distance above and to the right. The menu that shows up is small zoomed out, the bottom one is ‘set home’.
Setting that far up could bring you part back on the sheet.
image

1 Like

In Easel, I have the part fairly close to the origin, so it doesn’t seem like that would be the issue here:

I’ll try the click and hold, set home later today to see if that moves the part accordingly.

Anything else that might be the case here?

1 Like

G90/G91 Absolute and incremental positioning and the units come to mind.
But the sled looks right size, so units perhaps not.

Edit: You can also upload the g-code to take a look at.

GCode is here:
Maslow Sled.nc (54.7 KB)

1 Like

Strange thing going on here… nice find :slight_smile:
Have to figure out how i did it now

1 Like

For now, I can tag the post as “Danny doesn’t know what he’s doing, yet.” :slight_smile:

Let me know what you find.

I said it’s strange. bCNC was showing the file correctly and in my GC the part was far up to the right :man_shrugging:
I twiggeled with the g-code and reloaded but nothing seemed to work.
I clicked in the midle of the sheet and set home there (sure it was there before) and suddenly it was on the sheet.
Now i needed to replicate that. I downloaded the .nc again naming it -orig.nc and loaded that and it’s still on the sheet. Some woodoo or something going on.

1 Like

This used to happen to me all the time. Clicking the “define home” brings the project up onto the work surface.

Paul

Yep, this seemed to fix the problem for me. I didn’t know the click, hold, and Define Home option existed but now that I do I shouldn’t have to worry about this in the future.

In related news, I started my first cut last night and my computer went to sleep during the cut. I ended up with this:

There were some other problems in addition to the computer going to sleep. I’ll have to troubleshoot. But I was glad I finally got to make some cuts even if they were…sub-optimal.