Maslow Home Maslow Community Garden Newsletter

Issues with exporting Easel GCode

Hey everybody. I’m in the early stages of getting to know my Maslow CNC. I have the design side of things figured out. But the GCode generation is giving me headaches. I have decided on using Easel (unless there is a better / beginner-friendly option I’m unaware of). I have followed the tutorials on setting everything up. The issue is exporting. when I select to export GCode it downloads an .nc file. I tried opening that in ground control with zero success(it won’t show the project at all). Am I doing something wrong? I tried finding a nc to gcode converter but the only thing I found won’t run on any of the 10 PC’s we have here… Thanks in advance!

.nc files are another name for gcode so you should be good on that front. Can you try posting one of the generated .nc files here? Maybe we can take a look at it and see what is going wrong

After I posted here, I thought I’d try changing the file extension. After I changed it from .nc to .gcode the project did preview properly in Ground Control. I tried cutting the piece out, the first 2 sections it cut seems to work with no issue(although it didn’t cut through all the way). But once it was done cutting the second small section the z axis either only retracted slightly or not at all cutting it’s way toward the next section. That may have been my fault, but seeing as how the z axis properly retracted on the first 2 sections I thought it would do the same on the rest.

I have attached the file I used. Any feedback is greatly appreciated.

I am at the same stage, and had similar problems but I did find a solution. If you save to your desktop or downloads folder, the software won’t even see the .nc files. I now save straight to C:\ (not in any windows folders) and it works flawlessly.

Also, sounds like your Z-axis pitch is set wrong to me. If you haven’t, go into the Z-axis control, tell the sled to move 10mm up or down (whichever way you have more room) and measure how far the router clamp edge actually moves, be very accurate here. Then in Maslow Settings, adjust your Z-axis pitch up or down until the sled moves back and forth exactly 10mm. After you have the z-axis pitch set correctly, go back to Z-axis control, move the bit down until it almost touches the workpiece (I was moving .01mm at a time until I got it super close, but not touching). Then do “Define Zero”. There is also a setting in Maslow Settings called safe travel height, I set mine to 3mm, a lower setting may cause problems.

I have found that making your workpiece a millimeter or two thicker than it actually is will solve the cut-through problem. My material was .5" but I told Easel it was .6" thick which makes all my through cuts .1" deeper and it goes all the way through now. Live and learn. :slight_smile:

Jason

I’ll give these a try, and report back. Thanks!