Maslow Home Maslow Community Garden Newsletter

Fake Servo functionality

101 question. Based on my reading, I understood fake servo to be a placebo for the software instead of having an actual maslow attached. Does it do anything more than allow the system to be on? Does it simulate machine movements and “trace” your gcode on the screen? If so, how do you activate it beyond the secret to the universe password (which you can find if you look at the source code or you’ve seen the hitchhiker’s guide to the galaxy). If I press play, nothing happens. I’m unsure if this is expected or unusual behavior in this mode.

It does everything that a regular controller would do. When you hit play, it should run the gcode. Are you sure nothing is happening (like a zaxis move)

If the simulation time is approximating reality, my z axis pitch is -24, so it should start moving rather quickly and does nothing.

webcontrol log...

Initializing Logger
/home/pi/.WebControl/log.txt
Initializing Configuration
Camera initialized

raspbian gnu/linux


rpi
singledirectory

Using routines for Python > 3.5
Using routines for Python > 3.5
Starting Console Queue Processor
/home/pi/.WebControl/webcontrol-*.port
-$$$$$-
/home/pi/wiiControl/main.py
/home/pi/wiiControl
-$$$$$-
opening browser
Checking latest pyrelease.
starting Maslow GPIO button service
{“hostAddress”: “127.0.1.1:5000”}
connected
57de5d0d5af14fc9b98ddad7b2c68152
Attempting to re-establish connection to controller
starting UI
Trying to connect to controller on /dev/ttyAMA0

Connected on port /dev/ttyAMA0

I’m connected!
home-cutout2_0001.gcode
57de5d0d5af14fc9b98ddad7b2c68152
Sending Board Data
Sent Board Data
Sending Board Cut Data compressed
Latest pyrelease: 0.931
None
Sent Board Cut Data compressed
At loadUpdateFile
selectedGcode=./home-cutout2_0001.gcode
uncompressed:503683
compressed3D:97220
Sending Gcode compressed
Sent Gcode compressed
Connection Timed Out
57de5d0d5af14fc9b98ddad7b2c68152
57de5d0d5af14fc9b98ddad7b2c68152
Trying to connect to controller on /dev/ttyAMA0

Connected on port /dev/ttyAMA0

Connection Timed Out
stopping run
stopping run
Gcode stopped
Trying to connect to controller on /dev/ttyAMA0

Connected on port /dev/ttyAMA0

Sending: !
57de5d0d5af14fc9b98ddad7b2c68152

Summary

This text will be hidden

57de5d0d5af14fc9b98ddad7b2c68152

I’ve tried in development environment with version 932 and the single directory rpi version 931. In all the versions tried, (918 and up) it has never moved, only halted when play is pressed. Is there something that must be enabled to get it to work?

According to that screenshot, you’re not in fake servo mode. The top right button would be red and say fake servo. Are you running stock firmware? If so, you have to manually flash a version with fake servo enabled. If running holey calibration firmware, you should be able to dynamically change it via actions menu.

That is what I was looking for. I’ll see if I can program another arduino to act as my servoless maslow so it will simulate movement: No arduino, no fake servo mode. As I mentioned above, the rpi isn’t connected to anything.

Oh, yes, you have to have an arduino connected running the firmware.

1 Like