Maslow Home Maslow Community Garden Newsletter

Fatal error detected - Failed to execute script main

Hey guys! My eastbaysource-Maslow and the laptop with the ground controlle were hooked up on 230V life support. Yesterday my girlfriend pult the plug unintentionally. My attempts at resuscitation didn´t worked out.

Everytime I start up the groundcontrolle with the COM-connected, the software tells me “Fatal error detected - Failed to execute script main”.

I rebooted the arduino & the PC, I cleared the eeprom, I reinstalled the software on the arduino and the ground controlle. Couldn´t find anything on the problem so far. Does anybody have a solution or an ideas how to fix it?

The maslow wasn´t moving at all, just powered on.

Are you able to connect anything else to the same USB port? That would tell us if the issue is on the computer side or the Maslow side. The Maslow power supply is actually rated for 240v so I wouldn’t expect it to be hurt.

The USB port works. It even detects the version of the shield. But after a few seconds of connection the error window pops up and closes Ground Control.

230V is the basic in central europe. That shouldn´t be the problem. But what I meant to say was, that the error occurred after a lack of power to both the shield and the laptop.

What I figured out so far: the “main” script seams to be the data GroundControl_Windows/main/main.py. Why it´s not willing to execute it? I don´t know? Especially after I reinstalled all of the GroundControl-Software.

@Creative_Touch Have you looked at moving over to WebControl? If Ground Control is giving you issues, you can try WebControl and see if you are still getting the same error message. Search the forums here on how to move over to WC from GC. This may help in your troubleshooting, or at least may help to point to what is causing the issue if it is showing up in both.

Rick

1 Like