Maslow Home Maslow Community Garden

Feed Rate Question


#1

I have been playing with VisualCAMc and it has a option where you can set your feed rate. I have purposely set the feed rate slower just to be conservative. However I notice that when I generate the g code and load it into ground control it seems that ground control sets the feed rate faster than what programmed.

Does ground control set the fed rate regardless what the G-code feed rate is set at?


#2

GC will honor the feedrate set by a gcode line as that line is executed. That feedrate will remain in effect until a different one is encountered. I’m not certain, but I think that when GC first loads, before any gcode lines have been executed, the maximum feedrate as set in the (Advanced?) Settings will be in effect.


#3

I did never change the feedrate of my Maslow but it keeps jumping form 400mm/m to 800mm/m apparently with no logical sense.
Is this normal?


#4

it will only change based on the g-code, can you post the g-code to see what it
is telling the machine to do?

David Lang


#5

Hi David,
Attached are some of the files with g-codes I generated on Easel.
Let me know if there is something wrong with them.
ThanksDTW500 Molde ST3 1SET18.nc (28.5 KB)
DTW500 Molde ST5 1SET18.nc (26.8 KB)
DTW500 Molde ST4 1SET18.nc (29.4 KB)


#6

Hi david, could you take a look at my g-codes?


#7

Hi @oliverilg, looking at the three files, the feedrate is set by the gcodes in the file at 1000mm/minute by the ‘F1000’ . That’s probably faster than a Maslow can do at the current time. The GC AdvancedSetting/MaxFeedrate will override that if the MaxFeedrate is lower than the feedrate in the file, so there’s no need to change the files for that. Other than that, they look good. Using the Maslow to cut out the stations for boat building seems like an excellent application!

Something I like to do with files in Easel is to center them on 0,0 just before generating the gcode so that the resulting cuts are centered in the workarea of the Maslow. I ‘Select All’ , set the reference point to the center of the group, and change the coordinates of that point to 0,0. That looks odd in Easel because it is written for machines where ‘Home’ is in the lower left corner of the workarea, but moving the cuts to be centered on ‘Home’ makes life on the Maslow easier.


#8

Thanks for the analysis of the files. In future I will use 800mm/min as standard for cutting my parts. I’m using a pretty strong Bosch 1600 GFF router and I guess that helps.

I will also use your suggestion of centering on 0,0. I guess this will spread any error symmetrically, thus making a boat that will not have a “preferred side” (boat lingo for crooked lines!)…

The only thing that bothers me, is that my machine continues to switch between 800 and 400 mm/min, depending on where the router is. And it is no symmetrical pattern. Do you know if there is something else I can try to look into?


#9

Other than a ‘Fnnn’ parameter in a gcode line, I can’t think of what would do that. Can you post a section of gcode where this happens?


#10

It happens all the time, with all files, even when I center the machine from a corner, low or high position. It seems to me that this in it’s brain…


#11

If your g-code is lots of short moves, the maslow can end up being a lot slower
than expected due to the overhead of processing each line.

David Lang