Maslow Home Maslow Community Garden Newsletter

File goes small in Ground Control

Ok, I’m about to pull what’s left of my hair out… I’ve been trying to get my machine set up for weeks, worked through a bad motor shield, got everything calibrated, tried several design programs and finally settled on Fusion 360. I followed the YouTube videos to create just a basic design when five holes to just try things out on. Everything seemed to go fine during the CAM, but when I imported it into Ground Control it made it super tiny. I had to zoom in to see it. I was working in inches in Fusion 360, and it almost looks like it imported it in MM? Sorry if this is a dumb question, I’m just trying to get it to cut something and having all kinds of problems. I attached the code for the file that I’m working on if that helps. Thanks!!!

testproject.nc (2.1 KB)

I think you are exactly correct. From looking at the code what is going on is that Fusion is exporting the file without specifying inches or mm and Ground Control is assuming the project is in MM. I would recommend using a different post processor in fusion. There is a Maslow specific post processor for fusion out there somewhere, but I think a little searching in the forums will turn up other folks who say which settings work for them.

Looking at the actual gcode generated:

: (PGM, NAME="testproject")
; T1  D=0.25 CR=0 - ZMIN=-0.44 - FLAT END MILL
: G90 G40 G94
G17
G70
M26
; 2D CONTOUR1
M26
:T1 M6
M26
S5000 M3
H0
G0 X1.8735 Y-0.0451
G1 Z0.2 F13.1
Z-0.15
G17 G2 X-1.8754 Y0.0469 I-0.0009 J0.0009 F20
X1.8735 Y-0.0451 I-0.0009 J0.0009

I would expect to see either a G20 (mm) or a G21 (inches) in there but neither one is there so Ground Control has no way of knowing if the program is in inches or mm.

Here’s a version where I manually added a G21 to your program, let me know if that solves the issue.

testproject.nc (2.1 KB)