Firmware and Ground Control synchronization

  1. I updated gc and it says that it may have trouble without firmware update. I have downloaded 1.21 of each. Obvious my system doesn’t know that.
  2. I was already having a sled not keeping up error when just trying to demonstrate travel from gc for my father in law.
  3. Is Arduino nightly a problem because I tried doing this to mitigate such com as updates not syncing.
    ---- I had syncing problems like this when I first downloaded things and trying everything nothing worked, then unexplained: the “stars aligned” I re-read the assembly guide and still nothing tells me that I am missing anything. I’ve restarted and checked all cables. All lights are on z axis seemed glitchy at the beginning of my day but mysteriously began working. What would cause this many issues after I had previously been successful? For a change I thought I was all ready to really get moving with the thing.:neutral_face: Just trying to be patient.:expressionless::expressionless::neutral_face::expressionless::blush::pensive::sweat: