Maslow Home Maslow Community Garden Newsletter

Updating GC and firmware


#1

I have finally gotten around to making some chips, and I am looking forward to making more. I also want to add some extras like auto-zero and coordinated moves. To that end, I am pretty sure I need to update my GC and firmware as I am currently still on 1.06

That said, do I need to go through each iterative update to get to the latest, or is there a way to skip ahead to the latest firmware and GC? I realize all this will require a new calibration, which is fine, but I would prefer to not have to update twenty some firmwares on the arduino.

Thoughts? Suggestions? Any help would be appreciated.

Thanks much!


#2

I wouldn’t think you needed to update each of them when the fact is when we are starting from scratch we just jump on the one that is the latest. I believe I’ve skipped them before since I started and haven’t had a problem. Will you keep us updated on the chips?


#3

You can skip to the latest versions.
Just make sure you change both GroundControl and the Firmware because their same version numbers is also an indication of being tested together.
It does happen that one will get ahead of the other from time to time. But if each are the latest then I expect them to work well together despite Ground Control complaining about a difference.


#4

Thanks! That is really good news.

Since it looks like the windows version is still pending for 1.26, I’ll have a go with 1.25

I will definitely keep you updated. Hopefully I’ll have something to share by the weekend.


#5

This answers my question! I I’m currently setting up a new computer and I had postponed setting up my new computer and updating because of a job that I was needing to get done. I’m not really worried about the updates in version 1.26 about calibration as I’ve just recently calibrated anyway.
My computer had a hard time extracting the files. What app should I download to do that? It acted like it was extracting the files without downloading anything so I assumed I had WinZip or something already installed on the new / refurbed computer but it failed in the midst of the extraction. Unfortunately I don’t remember the error message.


#6

Sorry about that! I tried to talk someone through running the build over the phone but I’m not sure it worked and I won’t be able to test for another few days! I haven’t forgotten!


#7

No worries! considering I am still on 1.06 I don’t think I am in any hurry :wink:


#8

For future reference, winzip is pretty terrible (bloatware), I’d recommend anyone that’s using windows use (FOSS) 7zip instead.


#9

Thanks, @Jatt! And @bar this is also the first time I’ve updated in awhile too! Plus, considering the wording on calibration instructions are the only change (and I just did calibration) it’s all good! :sunglasses:


#10

The current versions of Windows will unzip without any extra software, bloated, free, or otherwise. Iirc this started in Windows XP but it’s been around for a long time. It’s called extract in the file manager


#11

If you’re getting error messages delete the file and download it again. While corrupted downloads are blamed for nearly as many ills as supposedly corrupted 3D printer firmware they actually do happen occasionally and it’s an easy fix to try.

If the zip file is good it shouldn’t matter which popular method is used to unzip it; if corrupted it won’t matter since it’s, well, corrupted