Maslow Home Maslow Community Garden Newsletter

Firmware not uploading

im new to this and im trying to set up my cnc but i keep getting an error when i upload the firmware can someone please help thank you in advance.

Arduino: 1.8.9 (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

cnc_ctrl_v1:36:20: error: Maslow.h: No such file or directory

compilation terminated.

exit status 1
Maslow.h: No such file or directory

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

If you downloaded the zip file, please unzip it rather than clicking into it to open the .ino. it won’t be able to find all the others unless it is fully decompressed.

1 Like

its still giving me same error

@Orob is right, this issue comes up a lot and it’s almost always caused by the file needing to be unzipped. It’s possible this is something new, but I would try starting fresh and be sure to open the the unzipped one and not the zipped version

i did a hard reset on my computer and started from step 1 kept having the same problem i think i wasn’t opening the unzip folder once i found it it worked thank you

1 Like