First steps in calibration


I have started calibration yesterday night. I came along several issues when trying to “Set Zero”. When I press 360CW, one of the motors is not turning exactly 360 degrees, but more like 300 only. The other issue is, that both motors have inverted movements. Instead of clockwise, they go counter-clockwise. Even after having exchanged cables 3 and 4 that connect to the board (I have built this Maslow from scratch myself, including the cables).

I am guessing the issue might be with the cables… is that possible? A strange thing is, that when I am running the “Test Motors” program, they turn perfectly well!! So it couldnt be an issue with the motors right?

I am a bit lost at the moment, and hope someone can help out!

1 Like

Are your motors set for top feed or bottom feed? Can you send a shot of your setup?

Thank you

at the moment, this is the only picture i can provide. It doesn’t include the chains yet.
To be honest I don’t know whether the motors are set for bottom or top feed, is it something I would have to change in GroundControl?

I searched the forum and now understand the terms, Ive got bottom feed with a bungee rope on top.

Does the left motor turn when it says it is testing the left motor? They could be plugged into the opposite ports.

Thanks for your replies.
I have checked it, but all motors turn in the testing program the way they should.

I have also repaired cables, that had some inconsistencies, but this didnt solve the issue…

Assuming that you have bottom feed, your groundcontrol.ini (found in your {username} folder) should have the setting:

chainoversprocketcomputed = 2.0

Could you check that for us please?

Kind regards, Gero

This happens to me every single time I’ve calibrated. I struggle through it not knowing the true cause. Possibly unplugging the arduino usb and power, closing GC and restarting can help.

Calibration is the worst part of Maslow. :disappointed:

I have checked it and it was set to 1.0. So now I have changed it. Thanks for the advise! Unfortunately I am not with my Maslow until tomorrow. I will let you know if it has worked out

1 Like

It can also be changed in GC in the advanced settings, and during calibration, but changing it in the .ini file works just as good. :+1:

I have changed the .ini file, and it actually worked!! Thank you so much! But a different problem occured. When pressing either of the calibration buttons (360°, 5°, 1°, 0.1°) the motors turn the same amount, about 300°…
This has not been the case before. Any ideas how that might have happened? I didn’t change anything else in the .ini file

Another thing that I have noticed is, that the magnets in the back of the motors run really hot very quickly. Is that normal? My motors don’t have the plastic cover in the back

Just for the record: I have found what was the issue concerning the misbehaving motors. Since the motors were not original Maslow parts, they had to be configured. The steps per revolution setting for the X and Y motor had to be changed.
If someone comes across this issue, they can send me a direct message and I can provide the details.

Thanks to everyone for the support. I have also changed to a top feed, since the setup with the bungee ropes didn’t work out well for me…

1 Like

What motors are you using?
If you ever want the chains back up, look into weight tensioning.
The worst but functional and cheap example: poor-man-weight-chain-tensioning
I’m much happier without the bungees.

Kind regards, Gero


I like your “poor man” solution. Something similar with bottles as weights was in my mind…

The motors I am using, are these off amazon:

1 Like

Kein Verkäufer liefert diesen Artikel aktuell nach Bahrain. :face_with_raised_eyebrow:

A nice find though.

Alternatively try this one

Maybe they do deliver to Bahrain?

En estos momentos, no hay vendedores que realicen envíos a Bahrein. :joy:

Don’t worry, i’ll find them on ali-ex and just wait longer :wink:

Edit: Dankeschoen!