Fusion 360 confusion

Dear Fusion 360 developers, you cork sucking iceholes. When I go the summabarging post processing, I do not get the options that all of the tutorials, videos and experts get. I suspect that it is a setting that I have made that is just not working. I do not get a configuration folder at all. I do not get the opportunity to use the genius plug in for the maslow. When I use grbl, which is a great suggestion/work around, the maslow moves as it should for the x and y axis, but Z keeps risin. The Z never goes into the wood. When I simulate the cutting process in Fusion 360, the levels and steps all move as one would expect, but the maslow moves in the opposite direction. The z keeps rising. My z axis is positioned properly in simulation, but it does not move and lower itself into the wood.

Maybe I started with the wrong file format or something. I am using a MAC, but Fusion 360 should not have that large or a differences between operating systems I would think.

Anyhow how do I turn on the configuration folder? If I do that I could possibly be able to download and use the Maslowcnc.cps. I would look forward to using it.

Strange but true, my problem is not seen by me as the input file, it is seen as the very last stage of the post process, I guess that is progress.

I get that Fusion is frustrating, which is part of the reason I’m transitioning to OnShape. I’ve run into a few infuriating issues with the program myself. The learning curve can be especially steep, but it’s a powerful enough program its definitely worth learning.

Could you please provide the nc file that you’re having trouble with? It’s hard to tell if this is an issue with your machine or the g code. The top of the work surface should be 0. If you’re going into the material, it will become a negative number. If you’re above the surface, it will be a positive number.

I’ve run the GRBL post almost exclusively myself. I’ve been meaning to test the Maslow-specific post myself, but haven’t had the time. If you want to add the Maslow post, follow these instructions. You’ll need to scroll down a little to get to the Mac OS instructions.

There are a couple of things that could be going wrong:

  1. The Z-Axis pitch in Ground Control is wrong. It could be possible that you need to change your axis pitch to a negative value to reverse it’s direction. If you’ve already run your machine successfully using g code from another program (such as MakerCAM), then ignore this.

  2. Your work origin is set up incorrectly in Fusion. If you’ve drawn your parts according to the top/front/left/right origin in Fusion, then they will be off by 90 degrees to the orientation you need to machine them. When you’re doing a New Setup, choose the “Select Z axis/plan & X axis”. You’ll then be able to select edges of your parts to set each direction. If your Z-axis is coming out reversed, you’ll want to check the box “Flip Z Axis”. Generally, you’ll also have to flip the X axis as well in order to get the right X-Y orientation, but this is not always the case.



It is strange that Fusion 360 is such a bugaboo for everyone, I have been reading the make magazine on CNC milling and it suggests Google sketchup as the platform.

I see how your three axis are oriented and I cannot get my axis to orient the same way. I am including the NC file, Ilook forward to hearing your feedback.

Looking forward to hearing back from you,


continued stool .nc (416 KB)

Fusion does have some issues. It can be a bit buggy, and I have fights with it sometimes when I’m laying out a sketch. The way it sketches reference other elements is a little tricky. Then again, I prefer Creo, which (I feel) handles external references much more gracefully.

Sketchup makes me shudder though. I’m sure the modern version is better than when I messed around with it, but I really don’t like the interface myself. Each to their own.

Anyways, onto the code!

So some interesting things are happening here. Your Z origin appears to be the bottom of the material rather than the top. With this, the Maslow will try to cut the air 3/4" above the work-surface, stepping down as it should until it just touches. I took your Z-heights and laid them out in this table to illustrate the point:


The original column is exactly what’s in your code. The difference tells us what the step-down is for each pass. The corrected column is what those heights should be. The really weird thing (to me) is that it has a pass at the stock top, which would just barely kiss the surface. That pass doesn’t help the cut and just takes extra time.

Based on what I’m seeing from the code, it looks like you set this point as your origin:


The other thing I noticed is that your feed rates are set way beyond the Maslow’s max speed. It doesn’t matter too much, because the firmware will throttle back to it’s own maximums and it should still cut alright. That will mess up your own planned feeds and speeds, though, because it can’t lower the RPM proportionally to the feedrate. This could cause rubbing, which will dull your tool and, in extreme cases, create a risk of fire. That would only happen though if your feed and speed were wildly different than what they should be, though.

Do you mind sharing your Fusion 360 file? I can run you through the process of setting up your toolpaths.

1 Like

It is great to talk to an expert! Or someone better than me anyway. I picked up on the fact that my z was in a different spot when you showed me an example z last message. I can send my fusion 360 file, yes. I am not adept at reading gcode just yet. But that is a skill i will be classically conditioned to learn i suspect. I will attempt to send my fusion360 file later today.


Thanks for asking about this file. Here is the shareable link: https://a360.co/2HxKhag

I hope that does it, I will try and correct the settings today, maybe one day I will have a stool!

I have no idea about F360. I looked at the .nc file and something seems not right.
That all cut are above surface is already mentioned but what I guess is supposed to be ‘rounded edges’ looks pretty weird.



@iltstb Thank you for sharing the file. I’m going to make a copy of it and make up a walk-through for you.

@Gero Interesting. I’m going to pour through the Fusion 360 CAM on my lunch and try to figure out what’s going on.


So this took longer than my lunch break, but I was able to diagnose the issues we saw in this thread.

Okay, problem the first:

Which we already pretty much knew was going on. It’s quite an easy fix. Click on “Box Point”, and several white dots will show up. You will want to click on one of the dots at the top of the model. I selected the center point, but you could quite as easily select a different point.

One other quick change I made was to flip the X axis. Not really necessary, but I think it helps. Another easy change:

Another issue I’m seeing is on the stock tab. You have offsets off the top and bottom. This will throw off your toolpaths, and might explain why it was trying to do a pass at the top of the part. You can see the stock above and below the part.

I changed the offsets to 0 off the top and bottom. The side offsets don’t matter as much.

That sums up the changes to the setup. Now, onto the tool paths. I’m going to look at tooling first. I switched the units to millimeters, partly because the model units are metric, and partly because I prefer it. This is another change that isn’t exactly necessary and you can do what you prefer.

The next tab we’re moving to is feeds and speeds. I’m actually not going to touch this right now, because I’m not sure what speeds you’ve found to work for your machine. The only note I’m going to make (and I have said this earlier) is that the listed speeds are too fast for the Maslow hardware. The firmware will automatically reduce speeds to make it work, but I just want to make sure 1) you’re aware of the issue, and 2) you know how to change it if need be. Personally, I’d make it 1000 mm/min (which is the max feedrate).

When you close the tool dialog, you will get this message:


Simply press yes, and it will update your feeds (and other settings) throughout the project.

Onto the issue @Gero noticed earlier. The handle pocket (I’m assuming it’s a handle) is defined by the wrong edge. The same goes for the exterior of the seat. Here, you have the top edge of the fillet selected. I think this is MASSIVELY confusing Fusion.


Also, you selected the top edges. You have it set up right to still make through cuts, so it’s not really a problem. However, I find that you have more control if you select the bottom edge.


There a couple of ways to deselect edges. The way I prefer (so you don’t loose all your selections), is to select the edge you don’t want, then click this X:

Note that in this example, I haven’t selected the handle hole or the holes for the legs. This is because I would make these pocket operations, not profiles. I’ll get into that a little later.

Moving on to the heights tab. There are three things I’ve changed. First, I set the clearance height to 5mm from stock top. Then I set the retract height to the same. I don’t like that Fusion decided to make these two separate values. I always have them set to the same value, and I always get a warning because of it. The last thing I did was set the bottom height to -0.5mm below selected contours. You could leave this set to stock bottom for profile cuts, I just find I have more control if I work from the contours. I set it to -0.5mm so that the bit goes beyond the material just a little. This will give you a clearer cut. If it’s just at 0, then a little skin of the veneer might get left behind.

Most of your settings for the passes tab look good. The only thing I would change is the finishing overlap. This is, again, personal preference, but I find it gives a cleaner edges.

On the linking tab (the last one), I will usually set the entry positions as well. This is probably just because I’m a control freak. I was able to position then away from the tabs so that they don’t interfere with each other.

The other thing I like to do is have lead-in and lead-out. It’s similar to the overlap I discussed earlier. Not necessary, but I feel like it leaves a cleaner edge. These are the settings I use:


So onto pockets. I would prefer to use pockets in these locations, that way there aren’t little scrap pieces that could get stuck. It will take a little longer to cut pockets than to profile, but I find the results are worth it. You could also use a profile cut and tabs to make sure the scrap piece doesn’t go anywhere. The settings will be very similar to the profile cuts. The only major change would be the step-over. You want this to be roughly 60% of your tool diameter.

So this is what I ended up with:

I then right-clicked on “Setup6” and selected post process. These are the settings I used for posting:

A parting note. Instead of setting each setting every time you make an operation, you can right click on any field and you will see two options, “Make Default” and “Make All Default”. I have used these features to set Maslow defaults for the operations I use the most.


Here’s the NC file I made, but I highly recommend you go through this process yourself to get more familiar with the CAM side of Fusion:

StoolforFool.nc (19.9 KB)



I went through several iterations, I tried the processes that you suggested Maynard, but I could not get the file to produce the results that I was looking for. I later realized that I was using the wrong endmill size in my files, once I corrected fro the endmill size I tried the file again, but I made the holes outside cuts just because I am thick headed. That was incorrect, then I did inside cuts on the leg holes, which yielded the correct size for the leg holes, on the length dimension, but not the width, this was supremely puzzling for me, why would the inside cut have the right size for the length, but not the width, since the width is 19 mm? So anyhow, now I will need to try pocket cuts, but is there any reason to suspect that the pocket would turn out differnt? Are the dimensions not the same with either selection?

I used the bottom on the model, I used inside cuts for the holes, I used tabs on the holes as well, I did not manipulate the the overlapping variable, and I wanted to go faster so I used the higher speed, and I did not do lead in or lead out, or place my starting points, I think that I would rather crawl before I can walk and allow myselfto add those details later. Anyhow I would like to know what you think about this NC file, and why I maybe got the results that I did. Once again the length dimension on the hole was correct the width was not and I did inside cuts to acheive the effect.
MAy 8th 2 stool .nc (312.8 KB)

MAy 8th 2 stool .nc (312.8 KB)

A lot of this is trial and error. It sounds like you’re on the right path! I know I covered a lot in my last post, and not all of it is necessary to get cutting. From what I can see, it looks like your programming parameters are good, but the geometry needs a little fixing.

Changing from a profile operation to a pocket operation should not have an appreciable difference in dimension. I use pocket operations only because they turn the internal scrap piece into sawdust. You could also add tabs to keep your scrap pieces from floating/flying around during cutting.

What material are you cutting? It sounds like you’re using 3/4" plywood, which isn’t actually 3/4" thick. The size there is a “nominal” size, and sheet thickness will often vary. I’ve found it usually comes out to 18mm. You will want to take your calipers and find the average thickness of the sheet. Then you will want to change your pocket size to match.

Also, if you make your holes the EXACT size of the tab that you’re insert, they’re not going to fit. When designing for CNC, add a small clearance factor to all of your pockets so that the tabs fit well. I’ve found that 0.015" or .4 mm gives me a pretty good fit, but you may find that you need more or less for your own projects.

I took a couple of quick dimensions from the model:

Length of Pocket: 55 mm
Width of Pocket: 23.3 mm

Length of Tab: 55.438 mm
Width of Tab: 19.05 mm

That’s a little all over the place. The length of the tab is significantly longer than the pocket. Also, the widths are pretty far off. Let’s say we already have the legs cut, and we want to re-cut the top so that the pockets match the legs. I would change the dimensions to:

Length of Pocket: 55.838 mm
Width of Pocket: 18.4 mm*

*I’m assuming the width of the plywood is 18 mm here.

@MeticulousMaynard Your step-by-step post above is useful, and wonder if you could make a separate topic with this info, so people can find it easier in the future, similar to the one posted this week regarding VisualCamc.

A question regarding your point about clearance. Are there is any addins or such that could do this automatically?

Thanks! There’s a YouTube video around somewhere that does a pretty good job of going step-by-step, but I could put together a good walkthrough in it’s own post so that it’s easy to find via search.

None that I’m aware of. I usually just add a CLR variable set to 0.4 mm, and then use it in my sketches or push/pull by -CLR, depending on the situation.

This video for flat-pack stool was helpful to me. Using the parameters in Fusion 360 for wood thickness, clearance, etc, means if in the future if I pick up different stock or the clearance was wrong, its easy to update your model.

I was able to follow along the video, (with a lot of stop and rewinds) and cut it on my Maslow. My clearance ended up being too tight on the first go, but still a good learning experience, and I can make a quick adjustment if I decide to make another stool :slightly_smiling_face:


Sorry Meticulous but something is fishy here :wink:
All screenshot are from Mac OS except this one:
It is from Win version of Fusion.

Right Click on Setup* > Post Process gives me that on Mac

I do not know how to use Maslow post under Mac :wink:

1 Like

Does this work?

1 Like

Yes I did - twice: as php and as html. And Post Procesor is greyed out “No post are available”
I am using post file from:


There are a ton of options (necessary, missing, unnecessary, etc) in the Fusion360 PostProcessor that we can configure, modify and otherwise make more useful for MaslowCNC, and inversely, with a program like Fusion360, designed for more advanced CNC machines, we can begin adding more complex functionality to MaslowCNC/Ground Control.

Here is the File: http://cam.autodesk.com/posts/post.php?name=maslowcnc 9

its pretty ‘readable’ as far as Code goes, and there are numerous videos on youtube of people editing their Post Processors for various purposes. ( https://www.youtube.com/results?search_query=fusion+360+post+processor+editing 4 )

(sorry for cut and paste as I do not know how to make a quote)

1 Like

It looks that I need *cps file not php.html
How to convert post.php to let say maslowPost.cps?

1 Like

I don’t have a .cps to compare but I would try to copy the text from Post for MaslowCNC into an editor and save as .cps. Use at own risk :wink:
Edit that uses unix format. (Not .rtf or other stuff)

1 Like