Mac > Fusion >Gcode > GroundControl Linux

I generated gcode from Fusion 360 (Mach3mill)

Sample of gcode is here:

(T2 D=6. CR=0. - ZMIN=-3. - FLAT END MILL)
G90 G94 G91.1 G40 G49 G17

T2 M6
S1780 M3
G0 X283.257 Y379.55
G43 Z10. H2
G1 Z-2.4 F30.
G18 G2 X283.857 Z-3. I0.6 K0.
G1 X284.457 F214.
G17 G3 X285.057 Y380.15 I0. J0.6
G1 Y629.323
X355.369 Y640.732
X355.261 Y642.311
X355.139 Y643.926
X353.476 Y665.974
X353.344 Y667.585
X351.544 Y689.594
X351.404 Y691.204
X349.497 Y713.182
X349.352 Y714.789
X347.372 Y736.747
X347.224 Y738.354
X345.209 Y760.301
X344.652 Y760.234
X337.498 Y759.362
X336.677 Y759.247
X329.574 Y758.249
X328.432 Y758.048
X321.229 Y756.789
… up to 500 lines of code

when opened in Ground Control I’ve got this:


In addition I do not see full gcode under Action>View gcode. Clicking Next shows last 50 lines of gcode.
I have Linux machine and GC v.1.13

Any idea where to start?
Which CNC machine is emulated by GC? There is a long list in Fusion 360.

Look for ‘grbl’ or ‘Maslow’. The one used above is for a higher-end machine :grin:.

That line for instance codes for a circular path in the ZX plane, beyond the current capabilities of the Maslow.

Here’s a site that can explain each piece of a gcode file, useful to troubleshoot or learn about gcode.


Here is some useful information. :blush:

1 Like

Thank you blurf! Changing to grbl helped but new problem popped ;-((
Many messages like “Oops, calculation cause error… send G1 instead… bla bla bla”
But more important - Z is wrong. I am trying to cut profiles from 3mm MDF. Within Fusion all looks good: simulation is OK. Z in gcode is Z0.6 ??? If I only solved this Z issue I should be fine.

I also tried to download Maslow post but how to instal it !!! I am running Mac version of Fusion - all tutorials are on Win platform ;-(( Under OS X there are no option to point to custom post)
Is there any free gcode program which accepts dxf and generate gcode acceptable by Maslow without errors? (FreeCAD accepts only graphics)

1 Like

Is your Z all + in the g-code? Could that be the point of origin?

Right now I am triple checking if hights and origin are all correct and align .

1 Like

Yesss!!! You’re right. Now I placed machine WCS on top of stock, set botom stock to -3mm and “voilais”

G0 X191.824 Y570.235
G1 Z-2.4 F30
X191.998 Y570.209 Z-2.824
X192.418 Y570.147 Z-3
X193.011 Y570.058 F214
G2 X193.516 Y569.376 I-0.088 J-0.593
G1 X192.754 Y564.265
I am going to shop and start cutting… ;-))


Would you mind changing the title to reflect the actual issue? (mac->fusion360)
That will make it easier to find for others with the same issues.
I was wondering how you run F360 under Linux :slight_smile:

1 Like

To make it clear: I am running Fusion360 on Mac OS X High Sierrra 10.13 on separate machine. MiniMac is converted to dedicated Linux station and runs GroundControl 1.13. Both machines are on the same wifi network and file exchange is not an issue. Linux see shared folders on Mac.
I will contact Fusion guys to solve loading Maslow post into Mac version of Fusion CAM. As blurf suggested, I am using grbl post for now and it is working fine (with couple of unsupported commands ignored by GC). Fusion CAM is complicated but once I figured it out it is quite good - smooth workflow from design to parts, to gcode within Fusion is priceless. Working in the same environment gives you consistent units, consistent orientation and so on. It would be great to have Maslow post in Fusion library - at the end simpler gcode and less chance for screwup. (We should have it here Post Library for Autodesk Fusion 360 | Autodesk Fusion 360 )
Thank you Gero for tip with Point of origin :wink:

1 Like

I’m glad to hear that progress is happening!

Those messages are a bother - they mean that the program that made the gcode used many tiny imprecise arcs to make a curved cut. Software precision limits would cause the Maslow to cut these wrong, sometimes very wrong. The firmware looks for those and changes the, from tiny arcs to tiny straight lines. The difference shouldn’t be visible in the finished cut. The message is the firmware telling that it has changed the command it received.

This is off topic of the original question but I saw this and created a pull request to reword that message to look less like something has gone wrong:

In Fusion360, I believe the ‘smoothing’ option in the 2D Contour menu will help prevent this by tieing in the small arcs into a smoother, longer, curve…

hope this helps,