GC crash on loading

I’m another newb. Sorry.

All went well with installation of GC until Port was set to Com 3 and received an error statement regarding valid chain length. Ground Control disappeared from the screen and can no longer be opened. Double clicking on “Launch Ground Control” opens a fleeting glimpse and is then gone.

I removed all folders and files and reloaded program with same result.

Read prior posts but cannot find the groundcontrol.ini file to add: propweightz = 1 and, if I did, would not know how to edit the file.

Windows 10
HP laptop, 64-bit, i3 core


Welcome to the Forum!
Do have a ‘anti virus’ running that could have false flagged GC as dangerous?

Are you confident to open a terminal/cmd-window on Win$10 to launch GC manualy?
That would keep the window open that would have more information.
Win guys can lead you there if you are up to it.

Kind regards, Gero

1 Like

Thanks, Gero!
Appreciate the help.
I wiped and re-loaded GC with anti-virus disabled with the same result.
I know how to open the cmd line but not how to run a program from there.
Again, thx for your help!

I don’t have a window computer to check, but i think GC is started with a .bat file.
I looked at it once and it just started a GC.exe in one folder deeper.
If you can find that folder with the .exe and open cmd-terminal there, type the name of the GC.exe in the cmd-window, i hope there is some information on why it’s not starting.

The log.txt in the GC folder could also have some info, as well as the kivy logs (on linux in .kivy/logs).

Gero -

You were right!
Although I turned off McAfee, Windows Defender was also running in the background.
I disabled it, keeping McAfee and all is working.
Thank you!