Ground control dead

So I’ve been cutting without problem last night. Did a little engraving with fcarve. Woke up today ready ready to try some vcarve and ground control will not stay running. It just opens like it’s going to and then closes. Went back 1.23 same thing. Redownload and extracted windows edition and same thing. Checked my .Kivy folder and changed to full screen to 0 and matched my resolution of LCD just for kicks. It does the same thing just doesn’t force full screen. Reflashed Arduino firmware 1.24, SAME THING! Rebooted laptop and unplugged Maslow from power and USB… SAME THING.


PS the log file is blank! The only other slight contributing factor could be there had been a notice"whining" sound coming somewhere from either the boards our the power supply I haven’t been able to truly isolate, but it hasn’t caused an issue thus far.

McAffey AV has been known to false trigger on GroundControl. Could that be the issue? Look for GroundControl.exe in the GroundControl folder inside the GCWindowsPortable folder… that’s what gets quarantined.


So through troubleshooting of my own. Steps I used to fix it:

  • Downloaded GC from source and unzipped
  • Followed all steps to prepare for dev environment and to run GC from source
  • GC still did not open
  • I noticed in command prompt the error noted in the screen shot
  • This happen before when installing in linux - after much previous research I found that PIL module is “Pillow”
  • ran python command to install pillow
  • GC magicaly open and retained all previous settings!

I went back to portable folders and tried to run and they will still not run. Not sure what is going on there. But it really doesn’t matter at this point as its working!!!